summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-01-09 21:54:55 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-01-09 21:54:55 +0000
commit3ed77c1c93bcaef06bee1c515917101d3c3aa854 (patch)
treeb778a61d727a662ad935cb190def2891fcb8718f /dev-python
parentVersion bump to 10.0.2. (diff)
downloadgentoo-2-3ed77c1c93bcaef06bee1c515917101d3c3aa854.tar.gz
gentoo-2-3ed77c1c93bcaef06bee1c515917101d3c3aa854.tar.bz2
gentoo-2-3ed77c1c93bcaef06bee1c515917101d3c3aa854.zip
bump of flake8 to 2.1.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flake8/ChangeLog9
-rw-r--r--dev-python/flake8/flake8-2.1.0.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/flake8/ChangeLog b/dev-python/flake8/ChangeLog
index 8f94fb9abb2a..bcb308af0aa2 100644
--- a/dev-python/flake8/ChangeLog
+++ b/dev-python/flake8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flake8
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.6 2013/12/11 19:30:09 floppym Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.7 2014/01/09 21:54:55 prometheanfire Exp $
+
+*flake8-2.1.0 (09 Jan 2014)
+
+ 09 Jan 2014; Matthew Thode <prometheanfire@gentoo.org> +flake8-2.1.0.ebuild:
+ bump of flake8 to 2.1.0
11 Dec 2013; Mike Gilbert <floppym@gentoo.org> flake8-2.0.ebuild:
Depend on dev-python/mccabe for tests, bug 493922 by Nikoli.
diff --git a/dev-python/flake8/flake8-2.1.0.ebuild b/dev-python/flake8/flake8-2.1.0.ebuild
new file mode 100644
index 000000000000..67b979832713
--- /dev/null
+++ b/dev-python/flake8/flake8-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.1.0.ebuild,v 1.1 2014/01/09 21:54:55 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="http://bitbucket.org/tarek/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND=">=dev-python/pyflakes-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.4.6[${PYTHON_USEDEP}]"
+PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test || die "tests failed under ${EPYTHON_}"
+}