summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-30 08:22:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-30 08:22:06 +0000
commit17e293d9449abc9b1b3e46b220b98b73d8f80834 (patch)
tree52d2d091f8830b98c332be1498f9430c16c79285 /dev-python
parentVersion bump. Drop useless USE=doc, it served no useful purpose. (diff)
downloadgentoo-2-17e293d9449abc9b1b3e46b220b98b73d8f80834.tar.gz
gentoo-2-17e293d9449abc9b1b3e46b220b98b73d8f80834.tar.bz2
gentoo-2-17e293d9449abc9b1b3e46b220b98b73d8f80834.zip
Version bump.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog8
-rw-r--r--dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch84
-rw-r--r--dev-python/pygobject/pygobject-3.4.1.1.ebuild116
3 files changed, 207 insertions, 1 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 5271f24faebc..9fbc65615773 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.180 2012/10/28 15:44:39 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.181 2012/10/30 08:22:06 eva Exp $
+
+*pygobject-3.4.1.1 (30 Oct 2012)
+
+ 30 Oct 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +pygobject-3.4.1.1.ebuild, +files/pygobject-3.4.1.1-make_check.patch:
+ Version bump.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> pygobject-2.28.6-r52.ebuild:
ia64/sh/sparc stable wrt #427544
diff --git a/dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch b/dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch
new file mode 100644
index 000000000000..7aa7058160e6
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch
@@ -0,0 +1,84 @@
+From d0885d5757f02f53dbc8036054a1ced7f727eb08 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 5 Nov 2010 23:39:08 +0100
+Subject: [PATCH] Do not build tests unless needed
+
+[Alexandre Rostovtsev <tetromino@gmail.com>: port to 2.90.1]
+---
+ tests/Makefile.am | 12 ++++++------
+ tests/runtests.py | 3 +++
+ 2 files changed, 9 insertions(+), 6 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 7a619bf..a3cbf57 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -1,5 +1,5 @@
+ CLEANFILES =
+-noinst_LTLIBRARIES = libgimarshallingtests.la
++check_LTLIBRARIES = libgimarshallingtests.la
+ test_typelibs = GIMarshallingTests-1.0.typelib
+
+ nodist_libgimarshallingtests_la_SOURCES = $(GI_DATADIR)/tests/gimarshallingtests.c $(GI_DATADIR)/tests/gimarshallingtests.h
+@@ -23,7 +23,7 @@ GIMarshallingTests-1.0.typelib: GIMarshallingTests-1.0.gir Makefile
+
+ # regress.c needs cairo
+ if ENABLE_CAIRO
+-noinst_LTLIBRARIES += libregress.la
++check_LTLIBRARIES += libregress.la
+ test_typelibs += Regress-1.0.typelib
+ nodist_libregress_la_SOURCES = $(GI_DATADIR)/tests/regress.c $(GI_DATADIR)/tests/regress.h
+ libregress_la_CFLAGS = $(GIO_CFLAGS) $(CAIRO_CFLAGS)
+@@ -52,7 +52,7 @@ gschemas.compiled: org.gnome.test.gschema.xml
+
+ CLEANFILES += Regress-1.0.gir Regress-1.0.typelib GIMarshallingTests-1.0.gir GIMarshallingTests-1.0.typelib gschemas.compiled
+
+-noinst_LTLIBRARIES += testhelper.la
++check_LTLIBRARIES += testhelper.la
+
+ testhelper_la_CFLAGS = -I$(top_srcdir)/gi/_gobject -I$(top_srcdir)/gi/_glib $(PYTHON_INCLUDES) $(GLIB_CFLAGS)
+ testhelper_la_LDFLAGS = -module -avoid-version
+@@ -72,7 +72,7 @@ testhelper.la: $(testhelper_la_OBJECTS) $(testhelper_la_DEPENDENCIES)
+ test -L $@ || $(LN_S) .libs/$@ $@
+
+
+-all: $(LTLIBRARIES:.la=.so)
++all: $(check_LTLIBRARIES:.la=.so)
+
+ EXTRA_DIST = \
+ compathelper.py \
+@@ -112,7 +112,7 @@ EXTRA_DIST = \
+ $(NULL)
+
+ clean-local:
+- rm -f $(LTLIBRARIES:.la=.so) file.txt~
++ rm -f $(check_LTLIBRARIES:.la=.so) file.txt~
+
+ DBUS_LAUNCH=$(shell which dbus-launch)
+ RUN_TESTS_ENV_VARS= \
+@@ -123,7 +123,7 @@ RUN_TESTS_ENV_VARS= \
+ MALLOC_PERTURB_=85 \
+ TESTS_BUILDDIR=$(builddir)
+
+-check-local: $(LTLIBRARIES:.la=.so) $(test_typelibs) gschemas.compiled
++check-local: $(check_LTLIBRARIES:.la=.so) $(test_typelibs) gschemas.compiled
+ @echo " CHECK Pyflakes"
+ @if type pyflakes >/dev/null 2>&1; then pyflakes $(top_srcdir); else echo "skipped, pyflakes not installed"; fi
+ @echo " CHECK PEP8"
+diff --git a/tests/runtests.py b/tests/runtests.py
+index c518fcc..35bb5c4 100755
+--- a/tests/runtests.py
++++ b/tests/runtests.py
+@@ -34,6 +34,9 @@ if sys.version_info[:2] == (2, 6):
+ unittest.TestCase.assertGreater = assertGreater
+ unittest.TestCase.assertIsInstance = assertIsInstance
+
++# Some tests fail with translated messages.
++os.environ["LC_ALL"] = "C"
++
+ if '--help' in sys.argv:
+ print("Usage: ./runtests.py <testfiles>")
+ sys.exit(0)
+--
+1.7.12.4
+
diff --git a/dev-python/pygobject/pygobject-3.4.1.1.ebuild b/dev-python/pygobject/pygobject-3.4.1.1.ebuild
new file mode 100644
index 000000000000..21b96e8f2a92
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.4.1.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.4.1.1.ebuild,v 1.1 2012/10/30 08:22:06 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6 3:3.1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 *-jython *-pypy-*"
+
+inherit autotools eutils gnome2 python virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test +threads" # doc
+REQUIRED_USE="test? ( cairo )"
+
+COMMON_DEPEND=">=dev-libs/glib-2.31.0:2
+ >=dev-libs/gobject-introspection-1.34.1.1
+ virtual/libffi
+ cairo? ( >=dev-python/pycairo-1.10.0 )"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[glib]
+ virtual/pkgconfig
+ test? (
+ dev-libs/atk[introspection]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )"
+# docs disabled for now per upstream default since they are very out of date
+# doc? (
+# app-text/docbook-xml-dtd:4.1.2
+# dev-libs/libxslt
+# >=app-text/docbook-xsl-stylesheets-1.70.1 )
+
+# We now disable introspection support in slot 2 per upstream recommendation
+# (see https://bugzilla.gnome.org/show_bug.cgi?id=642048#c9); however,
+# older versions of slot 2 installed their own site-packages/gi, and
+# slot 3 will collide with them.
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/pygtk-2.13
+ !<dev-python/pygobject-2.28.6-r50:2[introspection]"
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ # Hard-enable libffi support since both gobject-introspection and
+ # glib-2.29.x rdepend on it anyway
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --with-ffi
+ $(use_enable cairo)
+ $(use_enable threads thread)"
+
+ # Do not build tests if unneeded, bug #226345
+ epatch "${FILESDIR}/${PN}-3.4.1.1-make_check.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+ python_clean_py-compile_files
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ PYTHON="$(PYTHON)" gnome2_src_configure
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_src_compile
+}
+
+# FIXME: With python multiple ABI support, tests return 1 even when they pass
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+
+ testing() {
+ export XDG_CACHE_HOME="${T}/$(PYTHON --ABI)"
+ Xemake check PYTHON=$(PYTHON -a)
+ unset XDG_CACHE_HOME
+ }
+ python_execute_function -s testing
+ unset GIO_USE_VFS
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize gi
+}
+
+pkg_postrm() {
+ python_mod_cleanup gi
+}