summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-23 02:53:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-23 02:53:04 +0000
commit513bf5b9143bafb550c32ed22ebd3ad43339b259 (patch)
tree90afc795cdd739abfdbc848dcf0c815f3acaab42 /dev-python/whoosh
parentVersion bump. (diff)
downloadgentoo-2-513bf5b9143bafb550c32ed22ebd3ad43339b259.tar.gz
gentoo-2-513bf5b9143bafb550c32ed22ebd3ad43339b259.tar.bz2
gentoo-2-513bf5b9143bafb550c32ed22ebd3ad43339b259.zip
Bump
(Portage version: 2.2.6/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/ChangeLog7
-rw-r--r--dev-python/whoosh/whoosh-2.5.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/whoosh/ChangeLog b/dev-python/whoosh/ChangeLog
index 26db8483043d..eedb1a96196b 100644
--- a/dev-python/whoosh/ChangeLog
+++ b/dev-python/whoosh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/whoosh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/ChangeLog,v 1.16 2013/09/12 18:36:17 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/ChangeLog,v 1.17 2013/09/23 02:53:04 patrick Exp $
+
+*whoosh-2.5.4 (23 Sep 2013)
+
+ 23 Sep 2013; Patrick Lauer <patrick@gentoo.org> +whoosh-2.5.4.ebuild:
+ Bump
*whoosh-2.5.3 (12 Sep 2013)
diff --git a/dev-python/whoosh/whoosh-2.5.4.ebuild b/dev-python/whoosh/whoosh-2.5.4.ebuild
new file mode 100644
index 000000000000..50f122ac02e9
--- /dev/null
+++ b/dev-python/whoosh/whoosh-2.5.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/whoosh-2.5.4.ebuild,v 1.1 2013/09/23 02:53:04 patrick Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+MY_PN="Whoosh"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
+HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
+SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # (backport from upstream)
+ sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( README.txt )
+ use doc && local HTML_DOCS=( docs/build/html/_sources/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}