summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-26 07:33:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-26 07:33:48 +0000
commit237d93c24d2c5ffdd9e32a60287f4b57649a5720 (patch)
tree5257a976b9ff8588c8cd4b5fc0912c8afd18e48d /dev-python/webtest
parentDisable logic to probe gmp.h using the wrong toolchain #476336#19 by Michael ... (diff)
downloadgentoo-2-237d93c24d2c5ffdd9e32a60287f4b57649a5720.tar.gz
gentoo-2-237d93c24d2c5ffdd9e32a60287f4b57649a5720.tar.bz2
gentoo-2-237d93c24d2c5ffdd9e32a60287f4b57649a5720.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog7
-rw-r--r--dev-python/webtest/webtest-2.0.10.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 2d05bebb85a9..ed727312e0d5 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.72 2013/10/05 07:05:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.73 2013/11/26 07:33:48 patrick Exp $
+
+*webtest-2.0.10 (26 Nov 2013)
+
+ 26 Nov 2013; Patrick Lauer <patrick@gentoo.org> +webtest-2.0.10.ebuild:
+ Bump
05 Oct 2013; Pacho Ramos <pacho@gentoo.org> webtest-1.4.3-r1.ebuild:
Add missing PYTHON_REQUIRED_USE
diff --git a/dev-python/webtest/webtest-2.0.10.ebuild b/dev-python/webtest/webtest-2.0.10.ebuild
new file mode 100644
index 000000000000..194a564badae
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.10.ebuild,v 1.1 2013/11/26 07:33:48 patrick Exp $
+
+EAPI=5
+
+# sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ >=dev-python/webob-0.9.2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ python_targets_python2_6? ( dev-python/ordereddict[python_targets_python2_6] )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/paste
+ dev-python/pastedeploy )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Why is it so?
+ if [[ ${EPYTHON} == python3* ]]; then
+ rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}