summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-24 22:44:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-24 22:44:20 +0000
commitd774810b26264cafd4da96d6716ce46e4daa83a8 (patch)
tree9535513472a93c06f8f26db6c47fbdacb7acf1cf /dev-python/webob
parentStable on amd64 wrt bug #360361 (diff)
downloadgentoo-2-d774810b26264cafd4da96d6716ce46e4daa83a8.tar.gz
gentoo-2-d774810b26264cafd4da96d6716ce46e4daa83a8.tar.bz2
gentoo-2-d774810b26264cafd4da96d6716ce46e4daa83a8.zip
Version bump. Add doc USE flag (bug #351778).
(Portage version: 2.2.0_alpha28_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog8
-rw-r--r--dev-python/webob/webob-1.0.5.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 015746eba5e5..0e5b6a82a69d 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.27 2011/02/27 18:13:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.28 2011/03/24 22:44:20 arfrever Exp $
+
+*webob-1.0.5 (24 Mar 2011)
+
+ 24 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +webob-1.0.5.ebuild:
+ Version bump. Add "doc" USE flag (bug #351778).
27 Feb 2011; Brent Baude <ranger@gentoo.org> webob-1.0.1.ebuild:
stable ppc, bug 354165
diff --git a/dev-python/webob/webob-1.0.5.ebuild b/dev-python/webob/webob-1.0.5.ebuild
new file mode 100644
index 000000000000..07f0edc1e370
--- /dev/null
+++ b/dev-python/webob/webob-1.0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.5.ebuild,v 1.1 2011/03/24 22:44:20 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="WebOb"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://pythonpaste.org/webob/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+# Tests depend on some packages absent in the tree.
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}