summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-29 20:16:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-29 20:16:09 +0000
commit56369e36c5562833822cb516b801300505c6596c (patch)
tree975bcfc679459e318ea620322ddbfa1d211def36 /dev-python/webob
parentRemoved deprecated alpha (diff)
downloadgentoo-2-56369e36c5562833822cb516b801300505c6596c.tar.gz
gentoo-2-56369e36c5562833822cb516b801300505c6596c.tar.bz2
gentoo-2-56369e36c5562833822cb516b801300505c6596c.zip
Version bump.
(Portage version: 2.2.0_alpha30_p19/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog8
-rw-r--r--dev-python/webob/webob-1.0.7.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index a38fbc308406..043725eddfef 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.34 2011/04/29 20:10:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.35 2011/04/29 20:16:09 arfrever Exp $
+
+*webob-1.0.7 (29 Apr 2011)
+
+ 29 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +webob-1.0.7.ebuild:
+ Version bump.
29 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> webob-1.0.6.ebuild:
ppc64 stable wrt #365335
diff --git a/dev-python/webob/webob-1.0.7.ebuild b/dev-python/webob/webob-1.0.7.ebuild
new file mode 100644
index 000000000000..1d663eb2fc92
--- /dev/null
+++ b/dev-python/webob/webob-1.0.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.7.ebuild,v 1.1 2011/04/29 20:16:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="WebOb"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://pythonpaste.org/webob/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/webtest )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # https://bitbucket.org/ianb/webob/issue/11
+ sed -e "s/test_multidict_cgi/_&/" -i tests/test_misc.py
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}