summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-21 14:18:11 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-21 14:18:11 +0000
commit3ba158292d6cc382f779a1c8a933568ba00b6f50 (patch)
tree6214be2abdf425390843fcd7faca4348ab37bfa1 /dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild
parentCopy autotools files to build directory before eautoreconf, bug #462588. (diff)
downloadgentoo-2-3ba158292d6cc382f779a1c8a933568ba00b6f50.tar.gz
gentoo-2-3ba158292d6cc382f779a1c8a933568ba00b6f50.tar.bz2
gentoo-2-3ba158292d6cc382f779a1c8a933568ba00b6f50.zip
migration revbump, patch added skips 1 test affecting only pypy
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild')
-rw-r--r--dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild b/dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..d698add923dc
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/virtualenv-1.9.1-r1.ebuild,v 1.1 2013/03/21 14:18:11 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
+#DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="http://www.virtualenv.org/ http://pypi.python.org/pypi/virtualenv"
+SRC_URI="https://github.com/pypa/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS="docs/index.txt docs/news.txt"
+PYTHON_MODNAME="virtualenv.py virtualenv_support"
+
+# let the python eclass handle script versioning
+PATCHES=( "${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
+ "${FILESDIR}"/${P}-pypy.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && dohtml -r docs/_build/html/
+}
+
+python_test() {
+ nosetests "${S}"/tests || die
+}