summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-05-12 05:47:04 +0000
committerIan Delaney <idella4@gentoo.org>2015-05-12 05:47:04 +0000
commit88068dcd0d23db4d30179227b7f3664b869448ce (patch)
tree5757226c222813372a3088a83de8d3618291a6bc /dev-python/urllib3
parentAdd ruby22. (diff)
downloadgentoo-2-88068dcd0d23db4d30179227b7f3664b869448ce.tar.gz
gentoo-2-88068dcd0d23db4d30179227b7f3664b869448ce.tar.bz2
gentoo-2-88068dcd0d23db4d30179227b7f3664b869448ce.zip
re-write of test phase after further testing and probing of the testsuite, more planned
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/ChangeLog6
-rw-r--r--dev-python/urllib3/urllib3-1.10.3.ebuild17
2 files changed, 12 insertions, 11 deletions
diff --git a/dev-python/urllib3/ChangeLog b/dev-python/urllib3/ChangeLog
index 8c85a0c9e0ae..9c60bf62182c 100644
--- a/dev-python/urllib3/ChangeLog
+++ b/dev-python/urllib3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/urllib3
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/ChangeLog,v 1.36 2015/05/12 03:54:05 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/ChangeLog,v 1.37 2015/05/12 05:47:04 idella4 Exp $
+
+ 12 May 2015; Ian Delaney <idella4@gentoo.org> urllib3-1.10.3.ebuild:
+ re-write of test phase after further testing and probing of the testsuite,
+ more planned
*urllib3-1.10.3 (12 May 2015)
diff --git a/dev-python/urllib3/urllib3-1.10.3.ebuild b/dev-python/urllib3/urllib3-1.10.3.ebuild
index e1fa905953b4..8b2a64117961 100644
--- a/dev-python/urllib3/urllib3-1.10.3.ebuild
+++ b/dev-python/urllib3/urllib3-1.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/urllib3-1.10.3.ebuild,v 1.1 2015/05/12 03:54:05 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/urllib3-1.10.3.ebuild,v 1.2 2015/05/12 05:47:04 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -60,16 +60,13 @@ python_test() {
# test_verified is found to fail under py2.7 and pypy.
# upstream by their own admission describe the tests as flakey
- # __init__.py uses a local import requiring move to BUILD_DIR and copy of tests
- pushd "${BUILD_DIR}"/lib > /dev/null
- cp -ar "${S}"/test .
- # tests under with_dummyserver mssing a required file
- rm -rf test/with_dummyserver/ || die
- rm -f test/contrib/test_pyopenssl.py
- nosetests -v ./test/ || die "Tests fail with ${EPYTHON}"
+ # __init__.py uses a local import requiring use of PYTHONPATH=blank to offset
+ # Currently requires disabling FEATURES=network-sandbox (in make.conf)
+ # Failures currently occur under py2.7 with this disabled. After joint testing
+ # it's planned for this to have further investigation.
+ # Further adjustments to this phase to come
- rm -rf ./test/
- popd > /dev/null || die
+ PYTHONPATH= nosetests -v ./test/ || die "Tests fail with ${EPYTHON}"
}
python_install_all() {