summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2005-02-27 10:39:34 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2005-02-27 10:39:34 +0000
commit2330a25ffa354cbd060790005c56c0c80684559d (patch)
tree4d04bfba5acd9f12ca8d774481467c9072fdba1c /dev-python/urlgrabber
parentMade it prettier... (diff)
downloadgentoo-2-2330a25ffa354cbd060790005c56c0c80684559d.tar.gz
gentoo-2-2330a25ffa354cbd060790005c56c0c80684559d.tar.bz2
gentoo-2-2330a25ffa354cbd060790005c56c0c80684559d.zip
Marked stable on x86. Added description to metadata.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-python/urlgrabber')
-rw-r--r--dev-python/urlgrabber/ChangeLog8
-rw-r--r--dev-python/urlgrabber/metadata.xml28
-rw-r--r--dev-python/urlgrabber/urlgrabber-2.9.0.ebuild6
3 files changed, 37 insertions, 5 deletions
diff --git a/dev-python/urlgrabber/ChangeLog b/dev-python/urlgrabber/ChangeLog
index 1ecc60e7fcf0..f815c15637c7 100644
--- a/dev-python/urlgrabber/ChangeLog
+++ b/dev-python/urlgrabber/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/urlgrabber
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urlgrabber/ChangeLog,v 1.1 2004/12/09 23:15:07 kloeri Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urlgrabber/ChangeLog,v 1.2 2005/02/27 10:39:34 lucass Exp $
+
+ 27 Feb 2005; Lukasz Strzygowski <lucass@gentoo.org> metadata.xml,
+ urlgrabber-2.9.0.ebuild:
+ Marked stable on x86. Added description to metadata.
*urlgrabber-2.9.0 (10 Dec 2004)
diff --git a/dev-python/urlgrabber/metadata.xml b/dev-python/urlgrabber/metadata.xml
index de483c53568f..277fe04e4457 100644
--- a/dev-python/urlgrabber/metadata.xml
+++ b/dev-python/urlgrabber/metadata.xml
@@ -2,4 +2,32 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
+<longdescription>
+A high-level cross-protocol url-grabber.
+
+Using urlgrabber, data can be fetched in three basic ways:
+
+urlgrab(url) copy the file to the local filesystem
+urlopen(url) open the remote file and return a file object (like urllib2.urlopen)
+urlread(url) return the contents of the file as a string
+
+
+When using these functions (or methods), urlgrabber supports the following
+features:
+
+* identical behavior for http://, ftp://, and file:// urls
+* http keepalive - faster downloads of many files by using only a single
+ connection
+* byte ranges - fetch only a portion of the file
+* reget - for a urlgrab, resume a partial download
+* progress meters - the ability to report download progress automatically,
+ even when using urlopen!
+* throttling - restrict bandwidth usage
+* retries - automatically retry a download if it fails. The number of retries
+ and failure types are configurable.
+* authenticated server access for http and ftp
+* proxy support - support for authenticated http and ftp proxies
+* mirror groups - treat a list of mirrors as a single source, automatically
+ switching mirrors if there is a failure.
+</longdescription>
</pkgmetadata>
diff --git a/dev-python/urlgrabber/urlgrabber-2.9.0.ebuild b/dev-python/urlgrabber/urlgrabber-2.9.0.ebuild
index 5d637215bb7e..24ac81aabd56 100644
--- a/dev-python/urlgrabber/urlgrabber-2.9.0.ebuild
+++ b/dev-python/urlgrabber/urlgrabber-2.9.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urlgrabber/urlgrabber-2.9.0.ebuild,v 1.1 2004/12/09 23:15:07 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urlgrabber/urlgrabber-2.9.0.ebuild,v 1.2 2005/02/27 10:39:34 lucass Exp $
inherit distutils
@@ -10,5 +10,5 @@ SRC_URI="http://linux.duke.edu/projects/urlgrabber/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""