summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2013-08-24 07:49:44 +0000
committerJohann Schmitz <ercpe@gentoo.org>2013-08-24 07:49:44 +0000
commitc95ef2200bd41a1d18b8b10843d45b7b35a04fef (patch)
tree7c8a863cc51217e234900424e7a7f1a28bbd706b /dev-python/twython
parentFirst batch of ruby18-only packages is now removed, remove mask. (diff)
downloadgentoo-2-c95ef2200bd41a1d18b8b10843d45b7b35a04fef.tar.gz
gentoo-2-c95ef2200bd41a1d18b8b10843d45b7b35a04fef.tar.bz2
gentoo-2-c95ef2200bd41a1d18b8b10843d45b7b35a04fef.zip
New ebuild for twython (python library for using the twitter api) wrt #356235 written by me
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/ChangeLog10
-rw-r--r--dev-python/twython/metadata.xml12
-rw-r--r--dev-python/twython/twython-3.0.0.ebuild22
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/twython/ChangeLog b/dev-python/twython/ChangeLog
new file mode 100644
index 000000000000..592d7a5674a7
--- /dev/null
+++ b/dev-python/twython/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/twython
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twython/ChangeLog,v 1.1 2013/08/24 07:49:44 ercpe Exp $
+
+*twython-3.0.0 (24 Aug 2013)
+
+ 24 Aug 2013; Johann Schmitz <ercpe@gentoo.org> +metadata.xml,
+ +twython-3.0.0.ebuild:
+ New ebuild for twython (python library for using the twitter api) wrt #356235
+ written by me
diff --git a/dev-python/twython/metadata.xml b/dev-python/twython/metadata.xml
new file mode 100644
index 000000000000..704dc89951b5
--- /dev/null
+++ b/dev-python/twython/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ryanmcgrath/twython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/twython/twython-3.0.0.ebuild b/dev-python/twython/twython-3.0.0.ebuild
new file mode 100644
index 000000000000..0a30246ee8b5
--- /dev/null
+++ b/dev-python/twython/twython-3.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twython/twython-3.0.0.ebuild,v 1.1 2013/08/24 07:49:44 ercpe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.3.2[${PYTHON_USEDEP}]"