summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-14 03:54:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-14 03:54:33 +0000
commit56fa1f6df1c8f1464e5ce072f4ad50c3cdbe1e96 (patch)
tree07f668f050835d16c2ade7f9619d6a2f78a49831 /dev-python/twisted
parentRemove old. (diff)
downloadgentoo-2-56fa1f6df1c8f1464e5ce072f4ad50c3cdbe1e96.tar.gz
gentoo-2-56fa1f6df1c8f1464e5ce072f4ad50c3cdbe1e96.tar.bz2
gentoo-2-56fa1f6df1c8f1464e5ce072f4ad50c3cdbe1e96.zip
Bump
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/twisted-12.3.0.ebuild116
2 files changed, 122 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index d604af93c7f2..4f31626c16a9 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.159 2013/01/08 18:45:38 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.160 2013/01/14 03:54:33 patrick Exp $
+
+*twisted-12.3.0 (14 Jan 2013)
+
+ 14 Jan 2013; Patrick Lauer <patrick@gentoo.org> +twisted-12.3.0.ebuild:
+ Bump
08 Jan 2013; Mike Gilbert <floppym@gentoo.org> files/twistd.init:
Remove bashism, #450806 by kensington.
diff --git a/dev-python/twisted/twisted-12.3.0.ebuild b/dev-python/twisted/twisted-12.3.0.ebuild
new file mode 100644
index 000000000000..d21425dba935
--- /dev/null
+++ b/dev-python/twisted/twisted-12.3.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-12.3.0.ebuild,v 1.1 2013/01/14 03:54:33 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython"
+# A couple of failures (refcounting, version-checking), but sufficiently
+# functional to be useful, so restrict just the tests.
+PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
+MY_PACKAGE="Core"
+
+inherit eutils twisted versionator
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="crypt gtk serial"
+
+DEPEND="net-zope/zope-interface
+ crypt? ( >=dev-python/pyopenssl-0.10 )
+ gtk? ( dev-python/pygtk:2 )
+ serial? ( dev-python/pyserial )"
+RDEPEND="${DEPEND}"
+
+# Needed to make the sendmsg extension work
+# (see http://twistedmatrix.com/trac/ticket/5701 )
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CREDITS NEWS README"
+
+src_prepare(){
+ distutils_src_prepare
+
+ # Give a load-sensitive test a better chance of succeeding.
+ epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
+
+ # Skip a test if twisted conch is not available
+ # (see Twisted ticket #5703)
+ epatch "${FILESDIR}/twisted-12.1.0-remove-tests-conch-dependency.patch"
+
+ # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
+ epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed \
+ -e "s/test_newPluginsOnReadOnlyPath/_&/" \
+ -e "s/test_deployedMode/_&/" \
+ -i twisted/test/test_plugin.py
+ fi
+}
+
+src_test() {
+ testing() {
+ local exit_status="0"
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests-${PYTHON_ABI}" --no-compile || die "Installation of tests failed with $(python_get_implementation_and_version)"
+
+ pushd "${T}/tests-${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)" > /dev/null || die
+
+ # Skip broken tests.
+ sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
+
+ # http://twistedmatrix.com/trac/ticket/5375
+ sed -e "/class ZshIntegrationTestCase/,/^$/d" -i twisted/scripts/test/test_scripts.py || die "sed failed"
+
+ # tap2rpm is already skipped if rpm is not installed, but fails for me on a Gentoo box with it present.
+ # I currently lack the cycles to track this failure down.
+ rm twisted/scripts/test/test_tap2rpm.py
+
+ # Prevent it from pulling in plugins from already installed twisted packages.
+ rm -f twisted/plugins/__init__.py
+
+ # An empty file doesn't work because the tests check for doc strings in all packages.
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ if ! PYTHONPATH="." "${T}/tests-${PYTHON_ABI}${EPREFIX}/usr/bin/trial" twisted; then
+ if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
+ die "Tests failed with $(python_get_implementation_and_version)"
+ else
+ exit_status="1"
+ fi
+ fi
+
+ popd > /dev/null || die
+ return "${exit_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
+
+ postinstallational_preparation() {
+ touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
+
+ # Delete dropin.cache to avoid collisions.
+ # dropin.cache is regenerated in pkg_postinst().
+ rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
+ }
+ python_execute_function -q postinstallational_preparation
+
+ # Don't install index.xhtml page.
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+}