summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-14 13:51:51 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-14 13:51:51 +0000
commite971ef634e4d9096a525259ee9e6c8b1c2d3f6c1 (patch)
tree6170f75ebc71a0addc9a0ee9e9f0e9f8ec1bab23 /dev-python/twill
parentCleanup old. (diff)
downloadgentoo-2-e971ef634e4d9096a525259ee9e6c8b1c2d3f6c1.tar.gz
gentoo-2-e971ef634e4d9096a525259ee9e6c8b1c2d3f6c1.tar.bz2
gentoo-2-e971ef634e4d9096a525259ee9e6c8b1c2d3f6c1.zip
clean old python impls, drop unused IUSE add doc examples, doc build
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/twill')
-rw-r--r--dev-python/twill/ChangeLog5
-rw-r--r--dev-python/twill/twill-0.9-r1.ebuild26
2 files changed, 22 insertions, 9 deletions
diff --git a/dev-python/twill/ChangeLog b/dev-python/twill/ChangeLog
index fa5a277c9d42..ff19a6139f8f 100644
--- a/dev-python/twill/ChangeLog
+++ b/dev-python/twill/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/twill
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twill/ChangeLog,v 1.13 2014/03/31 21:18:11 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twill/ChangeLog,v 1.14 2014/06/14 13:51:51 idella4 Exp $
+
+ 14 Jun 2014; Ian Delaney <idella4@gentoo.org> twill-0.9-r1.ebuild:
+ clean old python impls, drop unused IUSE add doc examples, doc build
31 Mar 2014; Michał Górny <mgorny@gentoo.org> twill-0.9-r1.ebuild:
Add support for the new PyPy slotting.
diff --git a/dev-python/twill/twill-0.9-r1.ebuild b/dev-python/twill/twill-0.9-r1.ebuild
index bfdde71a2154..748b242bdc9a 100644
--- a/dev-python/twill/twill-0.9-r1.ebuild
+++ b/dev-python/twill/twill-0.9-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twill/twill-0.9-r1.ebuild,v 1.3 2014/03/31 21:18:11 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twill/twill-0.9-r1.ebuild,v 1.4 2014/06/14 13:51:51 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
+PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
@@ -17,15 +17,25 @@ SRC_URI="http://darcs.idyll.org/~t/projects/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="test"
+IUSE="doc examples"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/dnspython[${PYTHON_USEDEP}]' python2_7) )"
S="${WORKDIR}/${MY_P}"
+python_compile_all() {
+ if use doc; then
+ pushd doc > /dev/null
+ chmod +x make-epydoc.sh
+ ./make-epydoc.sh
+ popd> /dev/null
+ fi
+}
+
python_install_all() {
- dodoc -r doc/.
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
+ use doc && HTML_DOCS=( doc/epydoc-html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
}