summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-26 07:52:43 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-26 07:52:43 +0000
commitf8ccb668dfcbd1f76c63d7656b6fe3cc4161a728 (patch)
tree249b4485c15bc9ffdabd999db5ee51ed7df9f3ad /dev-python/testtools
parentCleanup. (diff)
downloadgentoo-2-f8ccb668dfcbd1f76c63d7656b6fe3cc4161a728.tar.gz
gentoo-2-f8ccb668dfcbd1f76c63d7656b6fe3cc4161a728.tar.bz2
gentoo-2-f8ccb668dfcbd1f76c63d7656b6fe3cc4161a728.zip
add bordering required for unittest2, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/ChangeLog6
-rw-r--r--dev-python/testtools/testtools-1.1.0.ebuild56
-rw-r--r--dev-python/testtools/testtools-1.2.0.ebuild42
-rw-r--r--dev-python/testtools/testtools-1.3.0.ebuild4
4 files changed, 7 insertions, 101 deletions
diff --git a/dev-python/testtools/ChangeLog b/dev-python/testtools/ChangeLog
index 6fd87a0e921d..0f04670a7542 100644
--- a/dev-python/testtools/ChangeLog
+++ b/dev-python/testtools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/testtools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.114 2014/12/24 08:51:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.115 2014/12/26 07:52:43 idella4 Exp $
+
+ 26 Dec 2014; Ian Delaney <idella4@gentoo.org> -testtools-1.1.0.ebuild,
+ -testtools-1.2.0.ebuild, testtools-1.3.0.ebuild:
+ add bordering required for unittest2, rm old
*testtools-1.3.0 (24 Dec 2014)
diff --git a/dev-python/testtools/testtools-1.1.0.ebuild b/dev-python/testtools/testtools-1.1.0.ebuild
deleted file mode 100644
index 39490804db40..000000000000
--- a/dev-python/testtools/testtools-1.1.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.1.0.ebuild,v 1.1 2014/10/15 11:53:56 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 versionator
-
-#SERIES="$(get_version_component_range 1-2)"
-SERIES="trunk"
-
-DESCRIPTION="Extensions to the Python unittest library"
-HOMEPAGE="https://launchpad.net/testtools http://pypi.python.org/pypi/testtools"
-SRC_URI="http://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_prepare_all() {
- # Take out failing tests
- # https://bugs.launchpad.net/testtools/+bug/1380918
- sed -e 's:test_test_module:_&:' -e 's:test_test_suite:_&:' \
- -i testtools/tests/test_distutilscmd.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- # Required to allow / ensure all impls to pass run of testsuite
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/testtools/testtools-1.2.0.ebuild b/dev-python/testtools/testtools-1.2.0.ebuild
deleted file mode 100644
index 65aec6411102..000000000000
--- a/dev-python/testtools/testtools-1.2.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.2.0.ebuild,v 1.3 2014/12/19 19:45:22 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 versionator
-
-#SERIES="$(get_version_component_range 1-2)"
-SERIES="trunk"
-
-DESCRIPTION="Extensions to the Python unittest library"
-HOMEPAGE="https://launchpad.net/testtools http://pypi.python.org/pypi/testtools"
-SRC_URI="http://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/testtools/testtools-1.3.0.ebuild b/dev-python/testtools/testtools-1.3.0.ebuild
index e2366ae5fb58..4848152d77cc 100644
--- a/dev-python/testtools/testtools-1.3.0.ebuild
+++ b/dev-python/testtools/testtools-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.3.0.ebuild,v 1.1 2014/12/24 08:51:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.3.0.ebuild,v 1.2 2014/12/26 07:52:43 idella4 Exp $
EAPI=5
@@ -22,7 +22,7 @@ IUSE="doc test"
RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
dev-python/extras[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]"
+ >=dev-python/unittest2-0.8.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )