summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-22 02:04:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-22 02:04:53 +0000
commitc705625e04033ec85f3101b232ed820fffeb1950 (patch)
tree645637f495f999feff5859fc75c82ea131d6db47 /dev-python/testtools
parentAppend PYTHON_USEDEP to the dependencies. (diff)
downloadgentoo-2-c705625e04033ec85f3101b232ed820fffeb1950.tar.gz
gentoo-2-c705625e04033ec85f3101b232ed820fffeb1950.tar.bz2
gentoo-2-c705625e04033ec85f3101b232ed820fffeb1950.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/ChangeLog7
-rw-r--r--dev-python/testtools/testtools-1.2.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/testtools/ChangeLog b/dev-python/testtools/ChangeLog
index abd81f14a38b..0d834a60816c 100644
--- a/dev-python/testtools/ChangeLog
+++ b/dev-python/testtools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testtools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.112 2014/12/19 19:45:22 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.113 2014/12/22 02:04:53 patrick Exp $
+
+*testtools-1.2.1 (22 Dec 2014)
+
+ 22 Dec 2014; Patrick Lauer <patrick@gentoo.org> +testtools-1.2.1.ebuild:
+ Bump
19 Dec 2014; Mike Gilbert <floppym@gentoo.org> testtools-1.2.0.ebuild:
Unconditionally depend on unittest2 at run/build time, bug 532720.
diff --git a/dev-python/testtools/testtools-1.2.1.ebuild b/dev-python/testtools/testtools-1.2.1.ebuild
new file mode 100644
index 000000000000..dbe8f09a13be
--- /dev/null
+++ b/dev-python/testtools/testtools-1.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.2.1.ebuild,v 1.1 2014/12/22 02:04:53 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 versionator
+
+#SERIES="$(get_version_component_range 1-2)"
+SERIES="trunk"
+
+DESCRIPTION="Extensions to the Python unittest library"
+HOMEPAGE="https://launchpad.net/testtools http://pypi.python.org/pypi/testtools"
+SRC_URI="http://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}