summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-20 15:16:08 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-20 15:16:08 +0000
commitb40634dfcd27e09aa3ae9ae473495c9cdf4e7dfb (patch)
treea3d7dc15ee30917fbac93c8dfff3ec2a847fc2f5 /dev-python/testify
parentbump; drop py2.6 support (diff)
downloadgentoo-2-b40634dfcd27e09aa3ae9ae473495c9cdf4e7dfb.tar.gz
gentoo-2-b40634dfcd27e09aa3ae9ae473495c9cdf4e7dfb.tar.bz2
gentoo-2-b40634dfcd27e09aa3ae9ae473495c9cdf4e7dfb.zip
bump; drop py2.6 add pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/ChangeLog8
-rw-r--r--dev-python/testify/testify-0.2.10.ebuild6
-rw-r--r--dev-python/testify/testify-0.3.0.ebuild4
-rw-r--r--dev-python/testify/testify-0.3.1.ebuild36
4 files changed, 48 insertions, 6 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index a01d025ff4eb..f0894d3c28ef 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.10 2014/05/03 08:12:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.11 2014/05/20 15:16:08 idella4 Exp $
+
+*testify-0.3.1 (20 May 2014)
+
+ 20 May 2014; Ian Delaney <idella4@gentoo.org> +testify-0.3.1.ebuild,
+ testify-0.2.10.ebuild, testify-0.3.0.ebuild:
+ bump; drop py2.6 add pypy support
*testify-0.3.0 (03 May 2014)
diff --git a/dev-python/testify/testify-0.2.10.ebuild b/dev-python/testify/testify-0.2.10.ebuild
index 26a29faa9178..6275c760f45f 100644
--- a/dev-python/testify/testify-0.2.10.ebuild
+++ b/dev-python/testify/testify-0.2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.2.10.ebuild,v 1.2 2013/04/05 05:44:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.2.10.ebuild,v 1.3 2014/05/20 15:16:08 idella4 Exp $
EAPI=5
@@ -19,7 +19,7 @@ IUSE="test"
RESTRICT="test"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
|| ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/testify/testify-0.3.0.ebuild b/dev-python/testify/testify-0.3.0.ebuild
index 37f59d971106..644ab7387f7f 100644
--- a/dev-python/testify/testify-0.3.0.ebuild
+++ b/dev-python/testify/testify-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.0.ebuild,v 1.1 2014/05/03 08:12:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.0.ebuild,v 1.2 2014/05/20 15:16:08 idella4 Exp $
EAPI=5
@@ -19,7 +19,7 @@ IUSE="test"
RESTRICT="test"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
|| ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/testify/testify-0.3.1.ebuild b/dev-python/testify/testify-0.3.1.ebuild
new file mode 100644
index 000000000000..e9ca56b9e742
--- /dev/null
+++ b/dev-python/testify/testify-0.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.1.ebuild,v 1.1 2014/05/20 15:16:08 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+DOCS="README.md"
+
+src_prepare_all() {
+ # Rm rogue test, Bug #438032
+ rm -f test/plugins//http_reporter_test.py
+}
+
+python_test() {
+ "${PYTHON}" bin/${PN} test || die
+}