summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-03-24 05:19:18 +0000
committerTim Harder <radhermit@gentoo.org>2015-03-24 05:19:18 +0000
commit092b26127ad19f5da522aad3d3457288f01840f4 (patch)
treea5d6085e77b17bce5edf495564d89563b696367b /dev-python/snakeoil
parentRemove old. (diff)
downloadgentoo-2-092b26127ad19f5da522aad3d3457288f01840f4.tar.gz
gentoo-2-092b26127ad19f5da522aad3d3457288f01840f4.tar.bz2
gentoo-2-092b26127ad19f5da522aad3d3457288f01840f4.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/ChangeLog8
-rw-r--r--dev-python/snakeoil/snakeoil-0.6.1.ebuild30
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild9
3 files changed, 40 insertions, 7 deletions
diff --git a/dev-python/snakeoil/ChangeLog b/dev-python/snakeoil/ChangeLog
index 65cc6a3194be..beab31ff5f8f 100644
--- a/dev-python/snakeoil/ChangeLog
+++ b/dev-python/snakeoil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/snakeoil
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.78 2015/02/19 18:39:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.79 2015/03/24 05:19:18 radhermit Exp $
+
+*snakeoil-0.6.1 (24 Mar 2015)
+
+ 24 Mar 2015; Tim Harder <radhermit@gentoo.org> +snakeoil-0.6.1.ebuild,
+ snakeoil-9999.ebuild:
+ Version bump.
19 Feb 2015; Tim Harder <radhermit@gentoo.org> snakeoil-0.5.3.ebuild:
Bump to EAPI 5 and drop py26 and py32 support.
diff --git a/dev-python/snakeoil/snakeoil-0.6.1.ebuild b/dev-python/snakeoil/snakeoil-0.6.1.ebuild
new file mode 100644
index 000000000000..e84ae37277cd
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.6.1.ebuild,v 1.1 2015/03/24 05:19:18 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Miscellaneous python utility code"
+HOMEPAGE="http://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index 7482d64506ab..9a78e3db0178 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-9999.ebuild,v 1.17 2015/02/19 17:26:11 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-9999.ebuild,v 1.18 2015/03/24 05:19:18 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -11,18 +11,15 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- SRC_URI="http://snakeoil.googlecode.com/files/${P}.tar.bz2"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
fi
DESCRIPTION="Miscellaneous python utility code"
-HOMEPAGE="http://snakeoil.googlecode.com/"
+HOMEPAGE="http://github.com/pkgcore/snakeoil"
LICENSE="BSD"
SLOT="0"
-DEPEND="!<sys-apps/pkgcore-0.4.7.8"
-RDEPEND=${DEPEND}
-
python_configure_all() {
# disable snakeoil 2to3 caching
unset PY2TO3_CACHEDIR