summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-06-18 05:53:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-06-18 05:53:01 +0000
commit3a301e23349538ca176eccd4441c013652929ad6 (patch)
treed92024bec27aa33f56ea3c1a43d6d4373a197ff2 /dev-python/simpletal
parentBump (diff)
downloadgentoo-2-3a301e23349538ca176eccd4441c013652929ad6.tar.gz
gentoo-2-3a301e23349538ca176eccd4441c013652929ad6.tar.bz2
gentoo-2-3a301e23349538ca176eccd4441c013652929ad6.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/simpletal')
-rw-r--r--dev-python/simpletal/ChangeLog7
-rw-r--r--dev-python/simpletal/simpletal-5.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/simpletal/ChangeLog b/dev-python/simpletal/ChangeLog
index 706913fc45c1..f37343c533e1 100644
--- a/dev-python/simpletal/ChangeLog
+++ b/dev-python/simpletal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simpletal
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.13 2015/01/09 10:29:37 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.14 2015/06/18 05:53:01 patrick Exp $
+
+*simpletal-5.2 (18 Jun 2015)
+
+ 18 Jun 2015; Patrick Lauer <patrick@gentoo.org> +simpletal-5.2.ebuild:
+ Bump
*simpletal-5.1-r1 (09 Jan 2015)
*simpletal-4.2-r1 (09 Jan 2015)
diff --git a/dev-python/simpletal/simpletal-5.2.ebuild b/dev-python/simpletal/simpletal-5.2.ebuild
new file mode 100644
index 000000000000..a629fb15d282
--- /dev/null
+++ b/dev-python/simpletal/simpletal-5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-5.2.ebuild,v 1.1 2015/06/18 05:53:01 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1
+
+MY_PN="SimpleTAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Stand alone Python implementation of the Zope TAL, TALES and METAL specs for HTML/XML templates"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ http://pypi.python.org/pypi/SimpleTAL"
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" \
+ -i tests/TALUtilsTests/TemplateCacheTestCases.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}