summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-01 20:10:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-01 20:10:23 +0000
commitc88884b781940ed42ceb9b0294582f4025ed2bb8 (patch)
treeadfd384954c7781e93813ed8676d6826f946e88d /dev-python/simplejson
parentclean up and merge from sunrise #270301 (diff)
downloadgentoo-2-c88884b781940ed42ceb9b0294582f4025ed2bb8.tar.gz
gentoo-2-c88884b781940ed42ceb9b0294582f4025ed2bb8.tar.bz2
gentoo-2-c88884b781940ed42ceb9b0294582f4025ed2bb8.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14176-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog8
-rw-r--r--dev-python/simplejson/simplejson-2.0.9-r1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 4e58aa9e12fa..e8f46afe1581 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.16 2009/07/20 00:26:49 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.17 2009/09/01 20:10:23 arfrever Exp $
+
+*simplejson-2.0.9-r1 (01 Sep 2009)
+
+ 01 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +simplejson-2.0.9-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
20 Jul 2009; Jeremy Olexa <darkside@gentoo.org> simplejson-2.0.9.ebuild:
amd64 stable, bug 277333
diff --git a/dev-python/simplejson/simplejson-2.0.9-r1.ebuild b/dev-python/simplejson/simplejson-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..804d6e4cfa1a
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.0.9-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.0.9-r1.ebuild,v 1.1 2009/09/01 20:10:23 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="A simple, fast, complete, correct and extensible JSON encoder and decoder."
+HOMEPAGE="http://undefined.org/python/#simplejson"
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+}