summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-17 12:01:17 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-17 12:01:17 +0000
commitbfed3ba0c516431315f3e5ccceff479644622a05 (patch)
tree18fe7a43382770d2f1766101093a732fb5c076aa /dev-python/sh
parentVersion Bump (diff)
downloadgentoo-2-bfed3ba0c516431315f3e5ccceff479644622a05.tar.gz
gentoo-2-bfed3ba0c516431315f3e5ccceff479644622a05.tar.bz2
gentoo-2-bfed3ba0c516431315f3e5ccceff479644622a05.zip
Version Bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/ChangeLog9
-rw-r--r--dev-python/sh/sh-1.11.ebuild26
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/sh/ChangeLog b/dev-python/sh/ChangeLog
index 43ce261b9134..676362ddb2e5 100644
--- a/dev-python/sh/ChangeLog
+++ b/dev-python/sh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sh
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sh/ChangeLog,v 1.7 2014/11/27 15:04:10 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sh/ChangeLog,v 1.8 2015/02/17 12:01:17 jlec Exp $
+
+*sh-1.11 (17 Feb 2015)
+
+ 17 Feb 2015; Justin Lecher <jlec@gentoo.org> +sh-1.11.ebuild:
+ Version Bump
27 Nov 2014; Pacho Ramos <pacho@gentoo.org> sh-1.09.ebuild:
Support python 3.4
diff --git a/dev-python/sh/sh-1.11.ebuild b/dev-python/sh/sh-1.11.ebuild
new file mode 100644
index 000000000000..94b9785434d1
--- /dev/null
+++ b/dev-python/sh/sh-1.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sh/sh-1.11.ebuild,v 1.1 2015/02/17 12:01:17 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{2,3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} test.py || die
+}