summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2013-02-24 10:07:09 +0000
committerSven Wegener <swegener@gentoo.org>2013-02-24 10:07:09 +0000
commit2000fd5e0e7aca8ecbe97bad991ba1a9360ec9f4 (patch)
tree870cbb711240a935c4326779ee7dc91563dcf92a /dev-python/runsnakerun/runsnakerun-2.0.1.ebuild
parentInitial commit, thanks to Martin Mokrejš, bug #408221. (diff)
downloadgentoo-2-2000fd5e0e7aca8ecbe97bad991ba1a9360ec9f4.tar.gz
gentoo-2-2000fd5e0e7aca8ecbe97bad991ba1a9360ec9f4.tar.bz2
gentoo-2-2000fd5e0e7aca8ecbe97bad991ba1a9360ec9f4.zip
Initial commit, thanks to Martin Mokrejš, bug #408225.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'dev-python/runsnakerun/runsnakerun-2.0.1.ebuild')
-rw-r--r--dev-python/runsnakerun/runsnakerun-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/runsnakerun/runsnakerun-2.0.1.ebuild b/dev-python/runsnakerun/runsnakerun-2.0.1.ebuild
new file mode 100644
index 000000000000..d874644fa489
--- /dev/null
+++ b/dev-python/runsnakerun/runsnakerun-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/runsnakerun/runsnakerun-2.0.1.ebuild,v 1.1 2013/02/24 10:07:09 swegener Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.4"
+RESTRICT_PYTHON_ABIS="3.*"
+
+MY_PN="RunSnakeRun"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+inherit distutils
+
+DESCRIPTION="GUI Viewer for Python profiling runs"
+HOMEPAGE="http://www.vrplumber.com/programming/runsnakerun/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/squaremap
+ dev-python/wxpython"
+
+S="${WORKDIR}"/${MY_P}