summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-26 05:55:08 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-26 05:55:08 +0000
commitcd3c8fefd9f61f5f2681c319358148ed0adfc539 (patch)
tree6d9f6e8294a45fd7906befccbc9dbe7b6d379578 /dev-python/restkit
parentRemove older version (diff)
downloadgentoo-2-cd3c8fefd9f61f5f2681c319358148ed0adfc539.tar.gz
gentoo-2-cd3c8fefd9f61f5f2681c319358148ed0adfc539.tar.bz2
gentoo-2-cd3c8fefd9f61f5f2681c319358148ed0adfc539.zip
Exclude tests the right way.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/restkit')
-rw-r--r--dev-python/restkit/ChangeLog9
-rw-r--r--dev-python/restkit/files/restkit-exclude-tests.patch25
-rw-r--r--dev-python/restkit/restkit-4.2.1-r1.ebuild (renamed from dev-python/restkit/restkit-4.2.0.ebuild)17
-rw-r--r--dev-python/restkit/restkit-4.2.1.ebuild59
4 files changed, 39 insertions, 71 deletions
diff --git a/dev-python/restkit/ChangeLog b/dev-python/restkit/ChangeLog
index 710a38a51078..84f3fd5cf763 100644
--- a/dev-python/restkit/ChangeLog
+++ b/dev-python/restkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/restkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.9 2013/02/10 09:02:37 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.10 2013/02/26 05:55:08 floppym Exp $
+
+*restkit-4.2.1-r1 (26 Feb 2013)
+
+ 26 Feb 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/restkit-exclude-tests.patch, +restkit-4.2.1-r1.ebuild,
+ -restkit-4.2.0.ebuild, -restkit-4.2.1.ebuild:
+ Exclude tests the right way.
*restkit-4.2.1 (10 Feb 2013)
diff --git a/dev-python/restkit/files/restkit-exclude-tests.patch b/dev-python/restkit/files/restkit-exclude-tests.patch
new file mode 100644
index 000000000000..5347967f5d28
--- /dev/null
+++ b/dev-python/restkit/files/restkit-exclude-tests.patch
@@ -0,0 +1,25 @@
+From 62a02a962f8b6460a379156108bde09f003821af Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 26 Feb 2013 00:43:01 -0500
+Subject: [PATCH] Don't install tests.
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index e6613c0..a6a5505 100755
+--- a/setup.py
++++ b/setup.py
+@@ -53,7 +53,7 @@ def main():
+ license = 'MIT',
+ url = 'http://benoitc.github.com/restkit',
+ classifiers = CLASSIFIERS,
+- packages = find_packages(),
++ packages = find_packages(exclude=['tests']),
+ data_files = DATA_FILES,
+ scripts = SCRIPTS,
+ zip_safe = False,
+--
+1.8.1.4
+
diff --git a/dev-python/restkit/restkit-4.2.0.ebuild b/dev-python/restkit/restkit-4.2.1-r1.ebuild
index 7f8564a9284e..66d02609ae02 100644
--- a/dev-python/restkit/restkit-4.2.0.ebuild
+++ b/dev-python/restkit/restkit-4.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.0.ebuild,v 1.3 2013/01/15 14:07:22 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.1-r1.ebuild,v 1.1 2013/02/26 05:55:08 floppym Exp $
EAPI=5
@@ -29,9 +29,9 @@ RDEPEND="cli? ( dev-python/ipython
>=dev-python/socketpool-0.5.0
>=dev-python/http-parser-0.7.7"
-src_compile() {
- distutils-r1_src_compile
+PATCHES=( "${FILESDIR}/${PN}-exclude-tests.patch" )
+python_compile_all() {
if use doc ; then
pushd doc > /dev/null
PYTHONPATH="${S}" emake html
@@ -40,20 +40,15 @@ src_compile() {
}
python_test() {
- nosetests -v tests
+ nosetests -v tests || die "Tests fail with ${EPYTHON}"
}
-src_install() {
- distutils-r1_src_install
-
- use cli || rm "${D}"/usr/bin/restcli*
+python_install_all() {
+ use cli || rm "${ED}"/usr/bin/restcli*
use doc && dohtml -r doc/_build/html/
if use examples ; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
-
- einfo "Remove tests to avoid file collisions"
- rm -rf $(find "${ED}" -name tests) || die
}
diff --git a/dev-python/restkit/restkit-4.2.1.ebuild b/dev-python/restkit/restkit-4.2.1.ebuild
deleted file mode 100644
index 0ffff73fbf19..000000000000
--- a/dev-python/restkit/restkit-4.2.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.1.ebuild,v 1.1 2013/02/10 09:02:37 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
-
-inherit distutils-r1
-
-DESCRIPTION="A HTTP ressource kit for Python."
-HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+cli doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx
- dev-python/epydoc )
- test? ( dev-python/webob
- >=dev-python/socketpool-0.5.0
- >=dev-python/http-parser-0.7.7 )"
-RDEPEND="cli? ( dev-python/ipython
- dev-python/setuptools[${PYTHON_USEDEP}] )
- dev-python/webob
- >=dev-python/socketpool-0.5.0
- >=dev-python/http-parser-0.7.7"
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc ; then
- pushd doc > /dev/null
- PYTHONPATH="${S}" emake html
- popd > /dev/null
- fi
-}
-
-python_test() {
- nosetests -v tests || die
-}
-
-src_install() {
- distutils-r1_src_install
-
- use cli || rm "${D}"/usr/bin/restcli*
-
- use doc && dohtml -r doc/_build/html/
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- einfo "Remove tests to avoid file collisions"
- rm -rf $(find "${D}" -name tests) || die
-}