summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-02-27 06:39:16 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-02-27 06:39:16 +0000
commit39824ea850970f0c22a2cba788210e418f5f5f6a (patch)
tree42510db2da94febd6cbbe995810ee0dec40b4698 /dev-python/pyx
parentUnmask USE=llvm for newer mesa. (diff)
downloadgentoo-2-39824ea850970f0c22a2cba788210e418f5f5f6a.tar.gz
gentoo-2-39824ea850970f0c22a2cba788210e418f5f5f6a.tar.bz2
gentoo-2-39824ea850970f0c22a2cba788210e418f5f5f6a.zip
Reintroduce mistakenly removed stable version. Thanks to Michael Sterrett <mr_bones_@gentoo.org> for spotting this
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'dev-python/pyx')
-rw-r--r--dev-python/pyx/ChangeLog8
-rw-r--r--dev-python/pyx/pyx-0.10-r1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index 2b130d799609..5e6148291d73 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.32 2013/02/02 14:00:01 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.33 2013/02/27 06:39:16 xarthisius Exp $
+
+*pyx-0.10-r1 (27 Feb 2013)
+
+ 27 Feb 2013; Kacper Kowalik <xarthisius@gentoo.org> +pyx-0.10-r1.ebuild:
+ Reintroduce mistakenly removed stable version. Thanks to Michael Sterrett
+ <mr_bones_@gentoo.org> for spotting this
02 Feb 2013; Kacper Kowalik <xarthisius@gentoo.org> -files/pyx-0.10.patch,
-pyx-0.10-r1.ebuild, -pyx-0.11.1.ebuild, -pyx-0.12.1.ebuild, -pyx-0.12.ebuild,
diff --git a/dev-python/pyx/pyx-0.10-r1.ebuild b/dev-python/pyx/pyx-0.10-r1.ebuild
new file mode 100644
index 000000000000..7d34dc9ae653
--- /dev/null
+++ b/dev-python/pyx/pyx-0.10-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10-r1.ebuild,v 1.6 2013/02/27 06:39:16 xarthisius Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES INSTALL"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}"/${P}.patch
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+
+ sed -i -e 's/^texipc =.*/texipc = 1/' pyxrc || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd "${S}/faq"
+ VARTEXFONTS="${T}"/fonts make pdf
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # The manual is not currently done because it needs mkhowto
+ # that's not currently available on our python ebuild
+ insinto /usr/share/doc/${P}/
+ doins faq/pyxfaq.pdf
+ fi
+}