summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-30 18:35:31 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-30 18:35:31 +0000
commit7431fb005d1275f02e0f668b210da1d5fd589b9a (patch)
tree5ac37917e7ad2ebc4b7f667ec7d31973dbf26f3b /dev-python/python-sqlparse
parentVersion Bump (diff)
downloadgentoo-2-7431fb005d1275f02e0f668b210da1d5fd589b9a.tar.gz
gentoo-2-7431fb005d1275f02e0f668b210da1d5fd589b9a.tar.bz2
gentoo-2-7431fb005d1275f02e0f668b210da1d5fd589b9a.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/python-sqlparse')
-rw-r--r--dev-python/python-sqlparse/ChangeLog7
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.16.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/python-sqlparse/ChangeLog b/dev-python/python-sqlparse/ChangeLog
index ac004b614496..5f3fac90d853 100644
--- a/dev-python/python-sqlparse/ChangeLog
+++ b/dev-python/python-sqlparse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-sqlparse
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.53 2015/06/07 15:46:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.54 2015/07/30 18:35:31 jlec Exp $
+
+*python-sqlparse-0.1.16 (30 Jul 2015)
+
+ 30 Jul 2015; Justin Lecher <jlec@gentoo.org> +python-sqlparse-0.1.16.ebuild:
+ Version Bump
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.16.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.16.ebuild
new file mode 100644
index 000000000000..5c8ea8f95cb9
--- /dev/null
+++ b/dev-python/python-sqlparse/python-sqlparse-0.1.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.16.ebuild,v 1.1 2015/07/30 18:35:31 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="http://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+# Required for running tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}"/${P#python-}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -w --no-diffs -n tests/ sqlparse/
+ py.test ./tests || die "testsuite failed ${EPYTHON}"
+ else
+ py.test tests || die "testsuite failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}