summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-06-07 23:47:50 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-06-07 23:47:50 +0000
commitc2a41b4bc184f24704b2ac61149f6dbc11171a09 (patch)
tree67fa9e087bb017aabef4f59639c2e0c37699a855 /dev-python/python-openid
parentStable on amd64 wrt bug 180989 (diff)
downloadgentoo-2-c2a41b4bc184f24704b2ac61149f6dbc11171a09.tar.gz
gentoo-2-c2a41b4bc184f24704b2ac61149f6dbc11171a09.tar.bz2
gentoo-2-c2a41b4bc184f24704b2ac61149f6dbc11171a09.zip
Version bump, added dep for pycrypto removed deps for python-yadis python-urljr. Thanks Paul Rauch <LightLan@lightlan.de>
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/ChangeLog10
-rw-r--r--dev-python/python-openid/files/digest-python-openid-2.0.03
-rw-r--r--dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff11
-rw-r--r--dev-python/python-openid/python-openid-2.0.0.ebuild47
4 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/python-openid/ChangeLog b/dev-python/python-openid/ChangeLog
index ac11b50b8abd..0c523377d988 100644
--- a/dev-python/python-openid/ChangeLog
+++ b/dev-python/python-openid/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-openid
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.4 2007/06/01 01:01:47 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.5 2007/06/07 23:47:50 pythonhead Exp $
+
+*python-openid-2.0.0 (07 Jun 2007)
+
+ 07 Jun 2007; Rob Cakebread <pythonhead@gentoo.org>
+ +files/python-openid-2.0.0-gentoo-test_fetchers.diff,
+ +python-openid-2.0.0.ebuild:
+ Version bump, added dep for pycrypto removed deps for python-yadis
+ python-urljr. Thanks Paul Rauch <LightLan@lightlan.de>
01 Jun 2007; Rob Cakebread <pythonhead@gentoo.org>
python-openid-1.2.0-r1.ebuild:
diff --git a/dev-python/python-openid/files/digest-python-openid-2.0.0 b/dev-python/python-openid/files/digest-python-openid-2.0.0
new file mode 100644
index 000000000000..fc00986b0d72
--- /dev/null
+++ b/dev-python/python-openid/files/digest-python-openid-2.0.0
@@ -0,0 +1,3 @@
+MD5 1946e8d65af1e38dc659c56ede066f3d python-openid-2.0.0.tar.bz2 458261
+RMD160 36bcbb3c23cb69c27761074bd4255f02fe147066 python-openid-2.0.0.tar.bz2 458261
+SHA256 8d208e0257bc35c9d227b7660d84b53ca3ccab333d50da20e0a69d32ebad6618 python-openid-2.0.0.tar.bz2 458261
diff --git a/dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff b/dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff
new file mode 100644
index 000000000000..67587a98533a
--- /dev/null
+++ b/dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff
@@ -0,0 +1,11 @@
+--- openid/test/test_fetchers.py.orig 2007-06-07 15:53:38.000000000 -0700
++++ openid/test/test_fetchers.py 2007-06-07 15:53:55.000000000 -0700
+@@ -8,6 +8,8 @@
+ # XXX: make these separate test cases
+
+ def failUnlessResponseExpected(expected, actual):
++ expected.final_url = expected.final_url.replace("localhost", "127.0.0.1")
++ actual.final_url = actual.final_url.replace("localhost", "127.0.0.1")
+ assert expected.final_url == actual.final_url, (
+ "%r != %r" % (expected.final_url, actual.final_url))
+ assert expected.status == actual.status
diff --git a/dev-python/python-openid/python-openid-2.0.0.ebuild b/dev-python/python-openid/python-openid-2.0.0.ebuild
new file mode 100644
index 000000000000..3a3b950fdfa0
--- /dev/null
+++ b/dev-python/python-openid/python-openid-2.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.0.0.ebuild,v 1.1 2007/06/07 23:47:50 pythonhead Exp $
+
+
+NEED_PYTHON=2.3
+PYTHON_MODNAME="openid"
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="OpenID support for servers and consumers."
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
+SRC_URI="http://www.openidenabled.com/resources/downloads/${PN}/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc examples mysql postgres sqlite"
+
+RDEPEND="|| ( <dev-lang/python-2.5 dev-python/elementtree )
+ || ( <dev-lang/python-2.5 dev-python/pycrypto )
+ postgres? ( dev-python/psycopg )
+ sqlite? ( >=dev-python/pysqlite-2.3.3 )
+ mysql? ( >=dev-python/mysql-python-1.2.2 )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #Patch to fix confusion with localhost/127.0.0.1
+ epatch ${FILESDIR}/${P}-gentoo-test_fetchers.diff
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml doc/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ #Remove test that requires running db server
+ sed -e '/storetest/d' -i admin/runtests
+ PYTHONPATH=. "${python}" admin/runtests || die "tests failed"
+}