summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2013-05-12 17:59:43 +0000
committerIan Whyman <thev00d00@gentoo.org>2013-05-12 17:59:43 +0000
commit10e28330489094e2d877c856b9943cca85662b9d (patch)
tree34e5ae369e5d5a98572ea7e8a74eddf7b8dee3c6 /dev-python/python-magic
parentdev-python/rdflib: Bump to new python r1 eclasses (diff)
downloadgentoo-2-10e28330489094e2d877c856b9943cca85662b9d.tar.gz
gentoo-2-10e28330489094e2d877c856b9943cca85662b9d.tar.bz2
gentoo-2-10e28330489094e2d877c856b9943cca85662b9d.zip
Initial import, ebuild by me.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/python-magic')
-rw-r--r--dev-python/python-magic/ChangeLog9
-rw-r--r--dev-python/python-magic/metadata.xml9
-rw-r--r--dev-python/python-magic/python-magic-0.4.3.ebuild19
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-magic/ChangeLog b/dev-python/python-magic/ChangeLog
new file mode 100644
index 000000000000..9c3323ea60af
--- /dev/null
+++ b/dev-python/python-magic/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/python-magic
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-magic/ChangeLog,v 1.1 2013/05/12 17:59:43 thev00d00 Exp $
+
+*python-magic-0.4.3 (12 May 2013)
+
+ 12 May 2013; Ian Whyman <thev00d00@gentoo.org> +metadata.xml,
+ +python-magic-0.4.3.ebuild:
+ Initial import, ebuild by me.
diff --git a/dev-python/python-magic/metadata.xml b/dev-python/python-magic/metadata.xml
new file mode 100644
index 000000000000..76a180a7e2bf
--- /dev/null
+++ b/dev-python/python-magic/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>thev00d00@gentoo.org</email>
+ <name>Ian Whyman</name>
+ </maintainer>
+ <longdescription>Python interface to the libmagic file type identification library.</longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-magic/python-magic-0.4.3.ebuild b/dev-python/python-magic/python-magic-0.4.3.ebuild
new file mode 100644
index 000000000000..50fe34d42ea3
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-magic/python-magic-0.4.3.ebuild,v 1.1 2013/05/12 17:59:43 thev00d00 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/file"