summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-15 02:07:00 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-15 02:07:00 +0000
commit41c2a41b1030213bd778154eef7a731c410981d8 (patch)
tree2c7706f73e20bdf3fb1a3ebb8fec84a55630c38d /dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild
parentadd dep. #17531 (diff)
downloadgentoo-2-41c2a41b1030213bd778154eef7a731c410981d8.tar.gz
gentoo-2-41c2a41b1030213bd778154eef7a731c410981d8.tar.bz2
gentoo-2-41c2a41b1030213bd778154eef7a731c410981d8.zip
version bump
Diffstat (limited to 'dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild b/dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild
new file mode 100644
index 000000000000..c6b0adceb52d
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.0.0_pre06.ebuild,v 1.1 2003/03/15 02:07:00 liquidx Exp $
+
+MYP=${P/_pre/pre}
+S=${WORKDIR}/${MYP}
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=net-nds/openldap-2.0.11"
+SLOT="0"
+LICENSE="public-domain" # NOTE: win32 section is under questionable license
+KEYWORDS="~x86 ~sparc ~alpha"
+
+inherit distutils
+
+src_compile() {
+ mv setup.cfg setup.cfg.orig
+ sed -e "s|/usr/local/openldap.*/lib|/usr/lib|" \
+ -e "s|/usr/local/openldap.*/include|/usr/include|" \
+ -e "s|libs = ldap lber|libs = ldap lber resolv|" \
+ setup.cfg.orig > setup.cfg || die
+
+ distutils_src_compile
+}