summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-05-30 01:32:45 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-05-30 01:32:45 +0000
commitc5168f081a0d34ac3d4076e0cf295becddacd49f (patch)
tree57bed68c6313d717eca25a766685cef297711c78 /dev-python/python-cinderclient
parentFix udisks-1.0.5-r1 compile with glibc-2.20 (bug #550758, thanks to Leonid K... (diff)
downloadgentoo-2-c5168f081a0d34ac3d4076e0cf295becddacd49f.tar.gz
gentoo-2-c5168f081a0d34ac3d4076e0cf295becddacd49f.tar.bz2
gentoo-2-c5168f081a0d34ac3d4076e0cf295becddacd49f.zip
bup
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/ChangeLog10
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.2.1.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/python-cinderclient/ChangeLog b/dev-python/python-cinderclient/ChangeLog
index 1e314c02a9c8..921a6c6e8fc1 100644
--- a/dev-python/python-cinderclient/ChangeLog
+++ b/dev-python/python-cinderclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-cinderclient
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.13 2014/11/18 21:43:46 prometheanfire Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.14 2015/05/30 01:32:45 prometheanfire Exp $
+
+*python-cinderclient-1.2.1 (30 May 2015)
+
+ 30 May 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +python-cinderclient-1.2.1.ebuild:
+ bup
*python-cinderclient-1.1.1 (18 Nov 2014)
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.2.1.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.2.1.ebuild
new file mode 100644
index 000000000000..c83ce7e2f0a8
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-1.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.2.1.ebuild,v 1.1 2015/05/30 01:32:45 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/tempest-lib-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run --parallel || die "tests failed under python2.7"
+ flake8 cinderclient/tests || die "run by flake8 over tests folder yielded error"
+}