summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-04 13:50:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-04 13:50:49 +0000
commitd26def5ae11d628b6602932ec824ab01fca70511 (patch)
tree153ba7f638f2809f2be1734491c1f6106902730a /dev-python/pytables
parentAdd ~mips keywords to qt-4.4.2 (diff)
downloadgentoo-2-d26def5ae11d628b6602932ec824ab01fca70511.tar.gz
gentoo-2-d26def5ae11d628b6602932ec824ab01fca70511.tar.bz2
gentoo-2-d26def5ae11d628b6602932ec824ab01fca70511.zip
Bump to 2.1, fixes #254654
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog9
-rw-r--r--dev-python/pytables/pytables-2.1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index 60a1292891e0..24c5fc48bdb3 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytables
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.26 2008/06/28 19:30:55 pythonhead Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.27 2009/02/04 13:50:49 patrick Exp $
+
+*pytables-2.1 (04 Feb 2009)
+
+ 04 Feb 2009; Patrick Lauer <patrick@gentoo.org> +pytables-2.1.ebuild:
+ Bump to 2.1, fixes #254654
*pytables-2.0.3 (28 Jun 2008)
diff --git a/dev-python/pytables/pytables-2.1.ebuild b/dev-python/pytables/pytables-2.1.ebuild
new file mode 100644
index 000000000000..64369c367e7f
--- /dev/null
+++ b/dev-python/pytables/pytables-2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.1.ebuild,v 1.1 2009/02/04 13:50:49 patrick Exp $
+
+EAPI="1"
+NEED_PYTHON="2.2"
+
+inherit distutils multilib
+
+DESCRIPTION="A package for managing hierarchical datasets built on top of the HDF5 library."
+SRC_URI="http://www.pytables.org/download/stable/tables-${PV}.tar.gz"
+HOMEPAGE="http://www.pytables.org/"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="BSD"
+IUSE="doc examples"
+
+DEPEND=">=sci-libs/hdf5-1.6.5
+ >=dev-python/numpy-1.0.3
+ dev-libs/lzo:2
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/tables-${PV}"
+
+
+src_install() {
+ cd "{S}"
+ DOCS="ANNOUNCE.txt MIGRATING_TO_2.x.txt RELEASE_NOTES.txt THANKS TODO.txt"
+
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ if use doc; then
+ cd doc
+
+ dohtml -r html/*
+
+ docinto text
+ dodoc text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r usersguide.pdf scripts/
+ fi
+}
+
+src_test() {
+ python_version
+ "${python}" setup.py install --root="${T}" --no-compile "$@" || die "temporary install failed"
+ PYTHONPATH="${T}/usr/$(get_libdir)/python${PYVER}/site-packages" "${python}" tables/tests/test_all.py || die "tests failed"
+}