summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-03 05:58:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-03 05:58:57 +0000
commit7d8332372034edce89c5e8d1e81b04b1b59ae934 (patch)
treeb2096bdef2bd74a5be216ac0db2148e098360e63 /dev-python/pyspf
parentInitial import. New dependency for dev-ruby/dotenv. (diff)
downloadgentoo-2-7d8332372034edce89c5e8d1e81b04b1b59ae934.tar.gz
gentoo-2-7d8332372034edce89c5e8d1e81b04b1b59ae934.tar.bz2
gentoo-2-7d8332372034edce89c5e8d1e81b04b1b59ae934.zip
bump; add IUSE ipv6 for new testsuite, drop py2.6 py3.2, update deps, initial patch by mjo
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/ChangeLog8
-rw-r--r--dev-python/pyspf/pyspf-2.0.9.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pyspf/ChangeLog b/dev-python/pyspf/ChangeLog
index 5f3c7205b249..4d5250542903 100644
--- a/dev-python/pyspf/ChangeLog
+++ b/dev-python/pyspf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyspf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/ChangeLog,v 1.25 2014/04/19 18:11:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/ChangeLog,v 1.26 2014/05/03 05:58:57 idella4 Exp $
+
+*pyspf-2.0.9 (03 May 2014)
+
+ 03 May 2014; Ian Delaney <idella4@gentoo.org> +pyspf-2.0.9.ebuild:
+ bump; add IUSE ipv6 for new testsuite, drop py2.6 py3.2, update deps, initial
+ patch by mjo
19 Apr 2014; Michał Górny <mgorny@gentoo.org> pyspf-2.0.8-r1.ebuild:
Use ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep().
diff --git a/dev-python/pyspf/pyspf-2.0.9.ebuild b/dev-python/pyspf/pyspf-2.0.9.ebuild
new file mode 100644
index 000000000000..1e942ccd268b
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.9.ebuild,v 1.1 2014/05/03 05:58:57 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ipv6?"
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
+HOMEPAGE="http://pypi.python.org/pypi/pyspf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 test"
+
+# >=python-3.3 comes with the built-in ipaddress module
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ipaddr[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ipv6 )"
+
+python_test() {
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}