summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-03 12:04:49 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-03 12:04:49 +0000
commit6003ff6b34b6b996770f0e0d0c9251b9d50f5a62 (patch)
treee0ff61cb710451963a91716ab55833139fb56058 /dev-python/pysnmp
parentDrop old versions. (diff)
downloadgentoo-2-6003ff6b34b6b996770f0e0d0c9251b9d50f5a62.tar.gz
gentoo-2-6003ff6b34b6b996770f0e0d0c9251b9d50f5a62.tar.bz2
gentoo-2-6003ff6b34b6b996770f0e0d0c9251b9d50f5a62.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha192/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/pysnmp')
-rw-r--r--dev-python/pysnmp/ChangeLog10
-rw-r--r--dev-python/pysnmp/pysnmp-4.2.2-r1.ebuild38
2 files changed, 45 insertions, 3 deletions
diff --git a/dev-python/pysnmp/ChangeLog b/dev-python/pysnmp/ChangeLog
index a8cb3e67111d..46e0e7171b46 100644
--- a/dev-python/pysnmp/ChangeLog
+++ b/dev-python/pysnmp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysnmp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysnmp/ChangeLog,v 1.53 2012/05/18 05:05:08 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysnmp/ChangeLog,v 1.54 2013/08/03 12:04:49 mgorny Exp $
+
+*pysnmp-4.2.2-r1 (03 Aug 2013)
+
+ 03 Aug 2013; Michał Górny <mgorny@gentoo.org> +pysnmp-4.2.2-r1.ebuild:
+ Migrate to distutils-r1.
18 May 2012; Patrick Lauer <patrick@gentoo.org> pysnmp-4.2.2.ebuild:
Bump for #416383
@@ -205,4 +210,3 @@
03 Jul 2003; Alastair Tse <liquidx@gentoo.org> pysnmp-2.0.8.ebuild:
new package contributed by Rob Cakebread <robc@myrealbox.com> (#23191)
-
diff --git a/dev-python/pysnmp/pysnmp-4.2.2-r1.ebuild b/dev-python/pysnmp/pysnmp-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..f2f1f898d982
--- /dev/null
+++ b/dev-python/pysnmp/pysnmp-4.2.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysnmp/pysnmp-4.2.2-r1.ebuild,v 1.1 2013/08/03 12:04:49 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python SNMP library"
+HOMEPAGE="http://pysnmp.sf.net/ http://pypi.python.org/pypi/pysnmp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pyasn1-0.1.2[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ local HTML_DOCS=( docs/*.{html,gif} )
+ use examples && local EXAMPLES=( examples/. docs/mibs )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "You may also be interested in the following packages: "
+ elog "dev-python/pysnmp-apps - example programs using pysnmp"
+ elog "dev-python/pysnmp-mibs - IETF and other mibs"
+ elog "net-libs/libsmi - to dump MIBs in python format"
+}