summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-15 09:53:12 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-15 09:53:12 +0000
commit47f3c0aa1ed10044738b0c8379a351e5b545db58 (patch)
treeb9cdbf2d6d784cf212265297fa85783eb881570f /dev-python/pyrex
parentsys-kernel/aufs-sources: Version BUmp (diff)
downloadgentoo-2-47f3c0aa1ed10044738b0c8379a351e5b545db58.tar.gz
gentoo-2-47f3c0aa1ed10044738b0c8379a351e5b545db58.tar.bz2
gentoo-2-47f3c0aa1ed10044738b0c8379a351e5b545db58.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyrex')
-rw-r--r--dev-python/pyrex/ChangeLog9
-rw-r--r--dev-python/pyrex/pyrex-0.9.9-r1.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/pyrex/ChangeLog b/dev-python/pyrex/ChangeLog
index 707536c91713..4b3cd081d2ba 100644
--- a/dev-python/pyrex/ChangeLog
+++ b/dev-python/pyrex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyrex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrex/ChangeLog,v 1.94 2012/12/02 06:06:23 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrex/ChangeLog,v 1.95 2013/02/15 09:53:12 mgorny Exp $
+
+*pyrex-0.9.9-r1 (15 Feb 2013)
+
+ 15 Feb 2013; Michał Górny <mgorny@gentoo.org> +pyrex-0.9.9-r1.ebuild:
+ Migrate to distutils-r1.
02 Dec 2012; Tim Harder <radhermit@gentoo.org> pyrex-0.9.9.ebuild:
Fix LICENSE (bug #445424 by ulm).
diff --git a/dev-python/pyrex/pyrex-0.9.9-r1.ebuild b/dev-python/pyrex/pyrex-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..fa2716e7cc74
--- /dev/null
+++ b/dev-python/pyrex/pyrex-0.9.9-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrex/pyrex-0.9.9-r1.ebuild,v 1.1 2013/02/15 09:53:12 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_P="Pyrex-${PV}"
+
+DESCRIPTION="A language for writing Python extension modules"
+HOMEPAGE="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/"
+SRC_URI="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+DOCS=( CHANGES.txt README.txt ToDo.txt USAGE.txt )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dohtml -A c -r Doc/.
+
+ if use examples; then
+ dodoc -r Demos
+ docompress -x /usr/share/doc/${PF}/Demos
+ fi
+}