summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-05 07:53:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-05 07:53:28 +0000
commit8ce7de0432de9699a1bb54a62d5812a8e21f7d32 (patch)
treefc2f96fd8e64047e800a6dcf49202139e00828b7 /dev-python/pyramid
parentBump (diff)
downloadgentoo-2-8ce7de0432de9699a1bb54a62d5812a8e21f7d32.tar.gz
gentoo-2-8ce7de0432de9699a1bb54a62d5812a8e21f7d32.tar.bz2
gentoo-2-8ce7de0432de9699a1bb54a62d5812a8e21f7d32.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyramid')
-rw-r--r--dev-python/pyramid/ChangeLog7
-rw-r--r--dev-python/pyramid/pyramid-1.5.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pyramid/ChangeLog b/dev-python/pyramid/ChangeLog
index 329ae3566958..8714cd056c32 100644
--- a/dev-python/pyramid/ChangeLog
+++ b/dev-python/pyramid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyramid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyramid/ChangeLog,v 1.2 2014/05/03 09:47:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyramid/ChangeLog,v 1.3 2014/06/05 07:53:28 patrick Exp $
+
+*pyramid-1.5.1 (05 Jun 2014)
+
+ 05 Jun 2014; Patrick Lauer <patrick@gentoo.org> +pyramid-1.5.1.ebuild:
+ Bump
*pyramid-1.5 (03 May 2014)
diff --git a/dev-python/pyramid/pyramid-1.5.1.ebuild b/dev-python/pyramid/pyramid-1.5.1.ebuild
new file mode 100644
index 000000000000..38c2f9f23a25
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyramid/pyramid-1.5.1.ebuild,v 1.1 2014/06/05 07:53:28 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+RESTRICT="test" # Can't package dependencies
+
+DESCRIPTION="A small open source Python web framework."
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#IUSE="test"
+# tests would pull in net-zope/zope-deprecation with its deps - not a good idea
+
+RDEPEND="
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ net-zope/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+ #test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ # dev-python/nose[${PYTHON_USEDEP}]
+ # dev-python/coverage[${PYTHON_USEDEP}]
+ # dev-python/virtualenv[${PYTHON_USEDEP}]
+ # )
+ #"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}