summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-13 09:40:27 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-13 09:40:27 +0000
commit88d0cabfffb1f9676409be9600b7c2abb3593167 (patch)
tree220ca59411aa41a6250f6eadb2853acff75c1393 /dev-python/pyquery
parentSuggest removing old setup symlinks as well. (diff)
downloadgentoo-2-88d0cabfffb1f9676409be9600b7c2abb3593167.tar.gz
gentoo-2-88d0cabfffb1f9676409be9600b7c2abb3593167.tar.bz2
gentoo-2-88d0cabfffb1f9676409be9600b7c2abb3593167.zip
bump; drop all those keywords to all add py3.4 support due to their absence in recent release of webtest, update test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyquery')
-rw-r--r--dev-python/pyquery/ChangeLog8
-rw-r--r--dev-python/pyquery/pyquery-1.2.9.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/pyquery/ChangeLog b/dev-python/pyquery/ChangeLog
index ea15e30a7a12..bc0b6f5ccc1b 100644
--- a/dev-python/pyquery/ChangeLog
+++ b/dev-python/pyquery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyquery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/ChangeLog,v 1.44 2014/06/18 16:01:12 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/ChangeLog,v 1.45 2014/10/13 09:40:27 idella4 Exp $
+
+*pyquery-1.2.9 (13 Oct 2014)
+
+ 13 Oct 2014; Ian Delaney <idella4@gentoo.org> +pyquery-1.2.9.ebuild:
+ bump; drop all those keywords to all add py3.4 support due to their absence in
+ recent release of webtest, update test phase
18 Jun 2014; Tobias Klausmann <klausman@gentoo.org> pyquery-1.2.4.ebuild:
Stable on alpha, bug #450174
diff --git a/dev-python/pyquery/pyquery-1.2.9.ebuild b/dev-python/pyquery/pyquery-1.2.9.ebuild
new file mode 100644
index 000000000000..1604e2a4446e
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.2.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/pyquery-1.2.9.ebuild,v 1.1 2014/10/13 09:40:27 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="https://github.com/gawel/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="beautifulsoup3 test"
+
+RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+ >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( beautifulsoup3 )"
+
+python_test() {
+ # The suite, it appears, requires this hard setting of PYTHONPATH!
+ PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
+}