summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2014-04-02 21:30:33 +0000
committerPatrick McLean <chutzpah@gentoo.org>2014-04-02 21:30:33 +0000
commitd9d98aa9d755a126723de12dbbbf5374cb650a39 (patch)
tree511eaedd234d682c5f773de4e2d9a6b2683c7cac /dev-python/pyparted
parentAdd python3_4 support. (diff)
downloadgentoo-2-d9d98aa9d755a126723de12dbbbf5374cb650a39.tar.gz
gentoo-2-d9d98aa9d755a126723de12dbbbf5374cb650a39.tar.bz2
gentoo-2-d9d98aa9d755a126723de12dbbbf5374cb650a39.zip
Revision bump, add python3_4 support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog7
-rw-r--r--dev-python/pyparted/pyparted-3.10-r1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index e180434708b3..693bb81b1ef2 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.85 2014/01/18 20:02:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.86 2014/04/02 21:30:33 chutzpah Exp $
+
+*pyparted-3.10-r1 (02 Apr 2014)
+
+ 02 Apr 2014; Patrick McLean <chutzpah@gentoo.org> +pyparted-3.10-r1.ebuild:
+ Revision bump, add python3_4 support.
18 Jan 2014; Agostino Sarubbo <ago@gentoo.org> pyparted-3.10.ebuild:
Stable for alpha, wrt bug #493130
diff --git a/dev-python/pyparted/pyparted-3.10-r1.ebuild b/dev-python/pyparted/pyparted-3.10-r1.ebuild
new file mode 100644
index 000000000000..9f77b7553392
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.10-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.10-r1.ebuild,v 1.1 2014/04/02 21:30:33 chutzpah Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+"
+# test? ( dev-python/pychecker )
+
+src_test() {
+ ewarn "Test suite disabled until dev-python/pychecker"
+ ewarn "is migrated to -r1.eclass"
+}