summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-03 00:57:28 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-08-03 00:57:28 +0000
commit561f542420641c9a8b38c1b1de66a2cefb4268a4 (patch)
treed390e876e8941473f6e95be1997651c1d1643830 /dev-python/pylint
parentRepoman happy (diff)
downloadgentoo-2-561f542420641c9a8b38c1b1de66a2cefb4268a4.tar.gz
gentoo-2-561f542420641c9a8b38c1b1de66a2cefb4268a4.tar.bz2
gentoo-2-561f542420641c9a8b38c1b1de66a2cefb4268a4.zip
add ${S} to PYTHONPATH for doc build
The sphinx build wasn't able to locate a pylint module due to the module not being in the path. This fixes bug #519408. (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog7
-rw-r--r--dev-python/pylint/pylint-1.4.4.ebuild4
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index fc27a650cab2..13420d942000 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.132 2015/07/02 20:20:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.133 2015/08/03 00:57:28 alunduil Exp $
+
+ 03 Aug 2015; Alex Brandt <alunduil@gentoo.org> pylint-1.4.4.ebuild:
+ add ${S} to PYTHONPATH for doc build The sphinx build wasn't able to locate a
+ pylint module due to the module not being in the path. This fixes bug
+ #519408.
*pylint-1.4.4 (02 Jul 2015)
diff --git a/dev-python/pylint/pylint-1.4.4.ebuild b/dev-python/pylint/pylint-1.4.4.ebuild
index 5fb9bb55d7ba..52d31e46f844 100644
--- a/dev-python/pylint/pylint-1.4.4.ebuild
+++ b/dev-python/pylint/pylint-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.4.4.ebuild,v 1.1 2015/07/02 20:20:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.4.4.ebuild,v 1.2 2015/08/03 00:57:28 alunduil Exp $
EAPI=5
@@ -32,7 +32,7 @@ DISTUTILS_IN_SOURCE_BUILD=1
python_compile_all() {
# selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && emake -C doc singlehtml
+ use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
}
python_test() {