summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-01-22 19:48:35 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-01-22 19:48:35 +0000
commitf7ee80502ea884cd32d188c13d7637ea0e0f2514 (patch)
treea9dd06e446bc986e59340cd6dd3f3aca5644a145 /dev-python/pyinotify
parentupdated LICENSE, bug #444504 (diff)
downloadgentoo-2-f7ee80502ea884cd32d188c13d7637ea0e0f2514.tar.gz
gentoo-2-f7ee80502ea884cd32d188c13d7637ea0e0f2514.tar.bz2
gentoo-2-f7ee80502ea884cd32d188c13d7637ea0e0f2514.zip
Make the python 3.3 workaround only apply for python 3.3 and above, fixes bug #453354
(Portage version: 2.1.11.43/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python/pyinotify')
-rw-r--r--dev-python/pyinotify/ChangeLog6
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/pyinotify/ChangeLog b/dev-python/pyinotify/ChangeLog
index c0295617a74b..a3614756b9cc 100644
--- a/dev-python/pyinotify/ChangeLog
+++ b/dev-python/pyinotify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyinotify
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.50 2013/01/18 23:10:21 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.51 2013/01/22 19:48:35 chutzpah Exp $
+
+ 22 Jan 2013; Patrick McLean <chutzpah@gentoo.org> pyinotify-0.9.4-r1.ebuild:
+ Make the python 3.3 workaround only apply for python 3.3 and above, fixes bug
+ #453354
18 Jan 2013; Patrick McLean <chutzpah@gentoo.org>
+files/pyinotify-0.9.4-workaround-sandbox-bug.patch,
diff --git a/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
index a4355a6e50d5..62cfaa2ced0c 100644
--- a/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
+++ b/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild,v 1.2 2013/01/18 23:10:21 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild,v 1.3 2013/01/22 19:48:35 chutzpah Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
@@ -19,9 +19,9 @@ IUSE="examples"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-workaround-sandbox-bug.patch
- distutils-r1_src_prepare
+python_prepare() {
+ local pythonver=${EPYTHON#python}
+ [[ ${pythonver//./} -ge 33 ]] && epatch "${FILESDIR}"/${P}-workaround-sandbox-bug.patch
}
python_install_all() {