summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-06 16:22:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-06 16:22:08 +0000
commit63cbcd25cb885b7909c13b6844214a4b47b94b84 (patch)
tree9abe099dbf3bf44f494d145fc48a88c265d8eb5d /dev-python/pygui
parentAdd elog message on where to find the kipi plugins (diff)
downloadgentoo-2-63cbcd25cb885b7909c13b6844214a4b47b94b84.tar.gz
gentoo-2-63cbcd25cb885b7909c13b6844214a4b47b94b84.tar.bz2
gentoo-2-63cbcd25cb885b7909c13b6844214a4b47b94b84.zip
Restrict 2.4 and 2.5 Python ABIs. Don't inherit eutils.eclass. Patch by Arfrever.
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygui')
-rw-r--r--dev-python/pygui/ChangeLog6
-rw-r--r--dev-python/pygui/pygui-2.5.3.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pygui/ChangeLog b/dev-python/pygui/ChangeLog
index 7e119da6afc4..48f6485429fe 100644
--- a/dev-python/pygui/ChangeLog
+++ b/dev-python/pygui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygui
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygui/ChangeLog,v 1.6 2011/08/05 18:11:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygui/ChangeLog,v 1.7 2011/08/06 16:22:08 hwoarang Exp $
+
+ 06 Aug 2011; Markos Chandras <hwoarang@gentoo.org> pygui-2.5.3.ebuild:
+ Restrict 2.4 and 2.5 Python ABIs. Don't inherit eutils.eclass. Patch by
+ Arfrever.
05 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> pygui-2.5.3.ebuild:
More ABI restrictions, thanks Arfrever
diff --git a/dev-python/pygui/pygui-2.5.3.ebuild b/dev-python/pygui/pygui-2.5.3.ebuild
index 9618bba50a52..e0c4cd0be6d7 100644
--- a/dev-python/pygui/pygui-2.5.3.ebuild
+++ b/dev-python/pygui/pygui-2.5.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygui/pygui-2.5.3.ebuild,v 1.2 2011/08/05 18:11:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygui/pygui-2.5.3.ebuild,v 1.3 2011/08/06 16:22:08 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypi-*"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython *-pypi-*"
-inherit distutils eutils
+inherit distutils
MY_P="PyGUI-${PV}"