summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-06-10 03:07:09 +0000
committerZac Medico <zmedico@gentoo.org>2015-06-10 03:07:09 +0000
commitf65a318e23679ed29583b21d0f6d92de50943d1f (patch)
treef5b95fa241a7ab11f94b588808d59aaac8c7b85a /dev-python/pyformance
parentAdd gnome herd, as discussed with floppym (diff)
downloadgentoo-2-f65a318e23679ed29583b21d0f6d92de50943d1f.tar.gz
gentoo-2-f65a318e23679ed29583b21d0f6d92de50943d1f.tar.bz2
gentoo-2-f65a318e23679ed29583b21d0f6d92de50943d1f.zip
Add pyformance package, with permission from Patrick McLean to add the python herd to metadata.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'dev-python/pyformance')
-rw-r--r--dev-python/pyformance/ChangeLog10
-rw-r--r--dev-python/pyformance/metadata.xml11
-rw-r--r--dev-python/pyformance/pyformance-0.3.2.ebuild28
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyformance/ChangeLog b/dev-python/pyformance/ChangeLog
new file mode 100644
index 000000000000..f81cacad49a2
--- /dev/null
+++ b/dev-python/pyformance/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pyformance
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyformance/ChangeLog,v 1.1 2015/06/10 03:07:09 zmedico Exp $
+
+*pyformance-0.3.2 (10 Jun 2015)
+
+ 10 Jun 2015; Zac Medico <zmedico@gentoo.org> +metadata.xml,
+ +pyformance-0.3.2.ebuild:
+ Add pyformance package, with permission from Patrick McLean to add the python
+ herd to metadata.
diff --git a/dev-python/pyformance/metadata.xml b/dev-python/pyformance/metadata.xml
new file mode 100644
index 000000000000..bc2ed4721eef
--- /dev/null
+++ b/dev-python/pyformance/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyformance</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyformance/pyformance-0.3.2.ebuild b/dev-python/pyformance/pyformance-0.3.2.ebuild
new file mode 100644
index 000000000000..5d45c26e2477
--- /dev/null
+++ b/dev-python/pyformance/pyformance-0.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyformance/pyformance-0.3.2.ebuild,v 1.1 2015/06/10 03:07:09 zmedico Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
+HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.python.org/pypi/pyformance/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# https://github.com/omergertel/pyformance/issues/18
+# https://github.com/omergertel/pyformance/pull/17
+RESTRICT="test"
+
+python_test() {
+ PYTHONPATH="${PWD}" python -m unittest \
+ $(find tests -name 'test_*.py' | LC_ALL=C sort | sed -e 's:/:.:' -e 's:.py$::') || die
+}