summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2011-09-05 22:36:05 +0000
committerMichael Januszewski <spock@gentoo.org>2011-09-05 22:36:05 +0000
commit5e2d626197b5f48dff0bef19a44c06ed8287d31d (patch)
tree2411fbee0cc6a84757529a827d8715b80875417d /dev-python/pycuda
parentFix emacs files install location (bug #381593 by Tom Prince). (diff)
downloadgentoo-2-5e2d626197b5f48dff0bef19a44c06ed8287d31d.tar.gz
gentoo-2-5e2d626197b5f48dff0bef19a44c06ed8287d31d.tar.bz2
gentoo-2-5e2d626197b5f48dff0bef19a44c06ed8287d31d.zip
Version bump.
(Portage version: 2.1.10.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/ChangeLog7
-rw-r--r--dev-python/pycuda/pycuda-2011.1.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pycuda/ChangeLog b/dev-python/pycuda/ChangeLog
index 23956c9e6a40..4a9d869e6d24 100644
--- a/dev-python/pycuda/ChangeLog
+++ b/dev-python/pycuda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycuda
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.10 2011/01/01 21:15:03 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.11 2011/09/05 22:36:05 spock Exp $
+
+*pycuda-2011.1.2 (05 Sep 2011)
+
+ 05 Sep 2011; Michał Januszewski <spock@gentoo.org> +pycuda-2011.1.2.ebuild:
+ Version bump.
01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pycuda-0.94.2.ebuild, pycuda-9999.ebuild:
diff --git a/dev-python/pycuda/pycuda-2011.1.2.ebuild b/dev-python/pycuda/pycuda-2011.1.2.ebuild
new file mode 100644
index 000000000000..4675a97747e1
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2011.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-2011.1.2.ebuild,v 1.1 2011/09/05 22:36:05 spock Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="http://mathema.tician.de/software/pycuda http://pypi.python.org/pypi/pycuda"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND="dev-python/decorator
+ dev-python/pytools
+ dev-libs/boost[python]
+ >=dev-util/nvidia-cuda-toolkit-2.0
+ >=dev-python/numpy-1.0.4
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myopts=""
+ use opengl && myopts="${myopts} --cuda-enable-gl"
+
+ ./configure.py --cuda-root="${ROOT}opt/cuda" \
+ --boost-python-libname=boost_python-mt \
+ --boost-thread-libname=boost_thread-mt \
+ ${myopts}
+}
+
+src_install()
+{
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}