summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-07-06 00:13:45 +0000
committerTim Harder <radhermit@gentoo.org>2015-07-06 00:13:45 +0000
commit4f43b3a9e42633d31c15446562cdf85b6284ad38 (patch)
tree0f0f53e621ed010a504462480c0afe080d5c9c50 /dev-python/pychroot
parentStable on amd64 and x86. (diff)
downloadgentoo-2-4f43b3a9e42633d31c15446562cdf85b6284ad38.tar.gz
gentoo-2-4f43b3a9e42633d31c15446562cdf85b6284ad38.tar.bz2
gentoo-2-4f43b3a9e42633d31c15446562cdf85b6284ad38.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/ChangeLog7
-rw-r--r--dev-python/pychroot/pychroot-0.9.10.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pychroot/ChangeLog b/dev-python/pychroot/ChangeLog
index 32be84f426eb..7feaf4725554 100644
--- a/dev-python/pychroot/ChangeLog
+++ b/dev-python/pychroot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pychroot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/ChangeLog,v 1.5 2015/06/03 20:54:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/ChangeLog,v 1.6 2015/07/06 00:13:45 radhermit Exp $
+
+*pychroot-0.9.10 (06 Jul 2015)
+
+ 06 Jul 2015; Tim Harder <radhermit@gentoo.org> +pychroot-0.9.10.ebuild:
+ Version bump.
03 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/pychroot/pychroot-0.9.10.ebuild b/dev-python/pychroot/pychroot-0.9.10.ebuild
new file mode 100644
index 000000000000..776189af50ba
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.9.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychroot/pychroot-0.9.10.ebuild,v 1.1 2015/07/06 00:13:45 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library that simplifies chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/snakeoil-0.6.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}