summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-01 00:43:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-01 00:43:45 +0000
commite1af679b37d5f7eccb9806f990d6531e9924f20f (patch)
tree2154bc68a50d0fb057eb01c94f98dac4b31ff1be /dev-python/pycdio
parentDelete older ebuild. (diff)
downloadgentoo-2-e1af679b37d5f7eccb9806f990d6531e9924f20f.tar.gz
gentoo-2-e1af679b37d5f7eccb9806f990d6531e9924f20f.tar.bz2
gentoo-2-e1af679b37d5f7eccb9806f990d6531e9924f20f.zip
Version bump.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/ChangeLog10
-rw-r--r--dev-python/pycdio/pycdio-0.17.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-python/pycdio/ChangeLog b/dev-python/pycdio/ChangeLog
index 0c0469287bf4..a7e05a60d51d 100644
--- a/dev-python/pycdio/ChangeLog
+++ b/dev-python/pycdio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycdio
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/ChangeLog,v 1.6 2009/12/24 23:23:49 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/ChangeLog,v 1.7 2010/11/01 00:43:45 arfrever Exp $
+
+*pycdio-0.17 (01 Nov 2010)
+
+ 01 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pycdio-0.16.ebuild, +pycdio-0.17.ebuild:
+ Version bump.
*pycdio-0.16 (25 Dec 2009)
diff --git a/dev-python/pycdio/pycdio-0.17.ebuild b/dev-python/pycdio/pycdio-0.17.ebuild
new file mode 100644
index 000000000000..85a2e042e641
--- /dev/null
+++ b/dev-python/pycdio/pycdio-0.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/pycdio-0.17.ebuild,v 1.1 2010/11/01 00:43:45 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="http://savannah.gnu.org/projects/libcdio/ http://pypi.python.org/pypi/pycdio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-libs/libcdio"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-python/setuptools"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="README.txt"
+PYTHON_MODNAME="cdio.py iso9660.py pycdio.py pyiso9660.py"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Remove obsolete sys.path and adjust 'data' paths in examples.
+ sed \
+ -e "s:^sys.path.insert.*::" \
+ -e "s:\.\./data:./data:g" \
+ -i example/*.py || die "sed failed"
+
+ # Disable failing tests.
+ sed -e "s/test_get_set/_&/" -i test/test-cdtext.py || die "sed failed"
+ sed -e "s/test_fs/_&/" -i test/test-isocopy.py || die "sed failed"
+}
+
+src_install(){
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example/{README,*.py} || die "doins failed"
+ doins -r data || die "doins failed"
+ fi
+}