summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-07 17:59:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-07 17:59:59 +0000
commitf6318217312f40d6de9f92b64945f53b483c6558 (patch)
tree0d1e082cd915b72eb1574ee71e12838f5296d1ae /dev-python/pycairo
parentppc stable #287438 (diff)
downloadgentoo-2-f6318217312f40d6de9f92b64945f53b483c6558.tar.gz
gentoo-2-f6318217312f40d6de9f92b64945f53b483c6558.tar.bz2
gentoo-2-f6318217312f40d6de9f92b64945f53b483c6558.zip
Fix tests (bug #285688).
(Portage version: 14510-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog6
-rw-r--r--dev-python/pycairo/pycairo-1.8.8.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index feb9f2c50890..fed4f8d2c4bd 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.79 2009/10/01 18:14:22 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.80 2009/10/07 17:59:59 arfrever Exp $
+
+ 07 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycairo-1.8.8.ebuild:
+ Fix tests (bug #285688).
01 Oct 2009; Tobias Klausmann <klausman@gentoo.org> pycairo-1.8.8.ebuild:
Stable on alpha, bug #285115
diff --git a/dev-python/pycairo/pycairo-1.8.8.ebuild b/dev-python/pycairo/pycairo-1.8.8.ebuild
index 45c0224e63ed..da3cf5f3f64b 100644
--- a/dev-python/pycairo/pycairo-1.8.8.ebuild
+++ b/dev-python/pycairo/pycairo-1.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.8.ebuild,v 1.10 2009/10/01 18:14:22 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.8.ebuild,v 1.11 2009/10/07 17:59:59 arfrever Exp $
EAPI="2"
@@ -58,8 +58,10 @@ src_compile() {
src_test() {
testing() {
+ cp src/__init__.py $(ls -d build-${PYTHON_ABI}/lib.*)/cairo
pushd test > /dev/null
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" -c "import examples_test; examples_test.test_examples(); examples_test.test_snippets_png()" || return 1
+ # examples_test.test_snippets_png() calls os.chdir().
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*):../$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" -c "import examples_test; examples_test.test_examples(); examples_test.test_snippets_png()" || return 1
popd > /dev/null
}
python_execute_function testing