summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-09-20 13:06:30 +0000
committerMichael Weber <xmw@gentoo.org>2014-09-20 13:06:30 +0000
commitf0e9a3c855f6dd9f93e54fa4729b8da112117d65 (patch)
tree62e11e8db7621c291a316e217a85a14d23d1f752 /dev-python/pyClamd
parentbump; upgrade deps, test failures filed in issue to upstream (diff)
downloadgentoo-2-f0e9a3c855f6dd9f93e54fa4729b8da112117d65.tar.gz
gentoo-2-f0e9a3c855f6dd9f93e54fa4729b8da112117d65.tar.bz2
gentoo-2-f0e9a3c855f6dd9f93e54fa4729b8da112117d65.zip
Initial import
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-python/pyClamd')
-rw-r--r--dev-python/pyClamd/ChangeLog9
-rw-r--r--dev-python/pyClamd/Manifest3
-rw-r--r--dev-python/pyClamd/metadata.xml8
-rw-r--r--dev-python/pyClamd/pyClamd-0.3.10.ebuild22
4 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyClamd/ChangeLog b/dev-python/pyClamd/ChangeLog
new file mode 100644
index 000000000000..8808edf0a9ab
--- /dev/null
+++ b/dev-python/pyClamd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pyClamd
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyClamd/ChangeLog,v 1.1 2014/09/20 13:06:30 xmw Exp $
+
+*pyClamd-0.3.10 (20 Sep 2014)
+
+ 20 Sep 2014; Michael Weber <xmw@gentoo.org> +metadata.xml,
+ +pyClamd-0.3.10.ebuild:
+ Initial import
diff --git a/dev-python/pyClamd/Manifest b/dev-python/pyClamd/Manifest
new file mode 100644
index 000000000000..c73c99490397
--- /dev/null
+++ b/dev-python/pyClamd/Manifest
@@ -0,0 +1,3 @@
+DIST pyClamd-0.3.10.tar.gz 8929 SHA256 ed77743c32298b151c881cc52a211e188bd24203ae402f2640def858c6a2bca7 SHA512 2c895fbc5897646ad5c23445062fb2e34a2db070471afd8356796f5f458d90b0da824af58b8ba762ce49572acaee6981881169eb33231085dac82ff0169fa2c8 WHIRLPOOL fa9ba64ab721169373572e552450fcee96db0499a9eeb336763ed2ea9e6f24328aece3b46a2c04ba2a6706f8d6a047ea0ef96f1fe53a6ae4663be0980d9e9c43
+EBUILD pyClamd-0.3.10.ebuild 506 SHA256 43f5682fc8512c720a0ebc156aba65469febef579ad25ac0162ab8529b8e163b SHA512 f9537b0c4ad335e74157ce2bfd62cbcc8859181f5852a01681ef33f8fe8303d4d9f3a2b4ad6a310496e6e390497a310ee531d35b2b0cd4868513dbdaaf4fab00 WHIRLPOOL 5507922c61496f048ea5bbaf9ff3db4b5b52df3822b173955d1b73ff54f001c8c7429a18dcfcf068199a719d9e742504046c3c06828d22fa7517d5f8bf42d5bd
+MISC metadata.xml 223 SHA256 89097f936927d56068988263e382edb683f359b27293955708e9ade4d256220d SHA512 c9f6a48b2aa05afdf73b8bd824c65480d76e54b659ca39928398c66f764d34faf186255d8aea034737424a962cf35151b610d078a01f8193b027c63e1e3c51b5 WHIRLPOOL 1ce20c98a7e177b8f510ef41f3935b0db5e04b2ecf465a683b2f2515f6a3043c33e6e9efc87f5aaaf59b2ed9be376d9d16bc8beff66b11aaa50ea899bfdc1f62
diff --git a/dev-python/pyClamd/metadata.xml b/dev-python/pyClamd/metadata.xml
new file mode 100644
index 000000000000..5b80fb94c393
--- /dev/null
+++ b/dev-python/pyClamd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyClamd/pyClamd-0.3.10.ebuild b/dev-python/pyClamd/pyClamd-0.3.10.ebuild
new file mode 100644
index 000000000000..6bcee3d949b0
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.3.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyClamd/pyClamd-0.3.10.ebuild,v 1.1 2014/09/20 13:06:30 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="http://xael.org/norman/python/pyclamd/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_prepare() {
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}