summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-01 06:59:46 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-01 06:59:46 +0000
commit4e7a187c7b25ea193b3b02e93d530a2c569e31d8 (patch)
treea16401c724e5505aa6f8f5ba66679df7c8b839f0 /dev-python/py2neo/py2neo-2.0.7.ebuild
parentbump; add test phase (diff)
downloadgentoo-2-4e7a187c7b25ea193b3b02e93d530a2c569e31d8.tar.gz
gentoo-2-4e7a187c7b25ea193b3b02e93d530a2c569e31d8.tar.bz2
gentoo-2-4e7a187c7b25ea193b3b02e93d530a2c569e31d8.zip
bump one rm one
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/py2neo/py2neo-2.0.7.ebuild')
-rw-r--r--dev-python/py2neo/py2neo-2.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/py2neo/py2neo-2.0.7.ebuild b/dev-python/py2neo/py2neo-2.0.7.ebuild
new file mode 100644
index 000000000000..a1d0ca5cef32
--- /dev/null
+++ b/dev-python/py2neo/py2neo-2.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py2neo/py2neo-2.0.7.ebuild,v 1.1 2015/07/01 06:59:46 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple and pragmatic library which accesses the Neo4j graph database"
+HOMEPAGE="http://py2neo.org"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_compile() {
+ # https://github.com/nigelsmall/py2neo/issues/380
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}