summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-07-20 06:45:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-07-20 06:45:55 +0000
commit177c146f6dba499a3677d05175606b7da1cc19e8 (patch)
treefec1112b40a46e0ecaa28e861e623cc266cd9c74 /dev-python/patsy
parentMark arm64/ia64/m68k/s390/sh stable #550288. (diff)
downloadgentoo-2-177c146f6dba499a3677d05175606b7da1cc19e8.tar.gz
gentoo-2-177c146f6dba499a3677d05175606b7da1cc19e8.tar.bz2
gentoo-2-177c146f6dba499a3677d05175606b7da1cc19e8.zip
Add more dependencies
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/patsy')
-rw-r--r--dev-python/patsy/ChangeLog7
-rw-r--r--dev-python/patsy/patsy-0.3.0-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/patsy/ChangeLog b/dev-python/patsy/ChangeLog
index 8401a906d193..60949e34a7db 100644
--- a/dev-python/patsy/ChangeLog
+++ b/dev-python/patsy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/patsy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/patsy/ChangeLog,v 1.7 2015/04/08 08:05:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/patsy/ChangeLog,v 1.8 2015/07/20 06:45:55 patrick Exp $
+
+*patsy-0.3.0-r1 (20 Jul 2015)
+
+ 20 Jul 2015; Patrick Lauer <patrick@gentoo.org> +patsy-0.3.0-r1.ebuild:
+ Add more dependencies
08 Apr 2015; Michał Górny <mgorny@gentoo.org> patsy-0.2.0.ebuild,
patsy-0.2.1.ebuild, patsy-0.3.0.ebuild:
diff --git a/dev-python/patsy/patsy-0.3.0-r1.ebuild b/dev-python/patsy/patsy-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..33115f4d1997
--- /dev/null
+++ b/dev-python/patsy/patsy-0.3.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/patsy/patsy-0.3.0-r1.ebuild,v 1.1 2015/07/20 06:45:55 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/_build/html/*
+}