summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 02:33:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 02:33:40 +0000
commiteb1badc4f37284226fd3c3be77d8060a24449888 (patch)
treed04fdede287d65d5f6900ae2f55ce31acb7b2830 /dev-python/pastescript
parent0.6.14 version bump. (diff)
downloadgentoo-2-eb1badc4f37284226fd3c3be77d8060a24449888.tar.gz
gentoo-2-eb1badc4f37284226fd3c3be77d8060a24449888.tar.bz2
gentoo-2-eb1badc4f37284226fd3c3be77d8060a24449888.zip
Set SUPPORT_PYTHON_ABIS. Delete "test" USE flag.
(Portage version: 14469-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/ChangeLog6
-rw-r--r--dev-python/pastescript/pastescript-1.7.3.ebuild45
2 files changed, 27 insertions, 24 deletions
diff --git a/dev-python/pastescript/ChangeLog b/dev-python/pastescript/ChangeLog
index 3cf74a81b413..a83d44058eee 100644
--- a/dev-python/pastescript/ChangeLog
+++ b/dev-python/pastescript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pastescript
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.6 2009/04/26 09:53:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.7 2009/10/01 02:33:40 arfrever Exp $
+
+ 01 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pastescript-1.7.3.ebuild:
+ Set SUPPORT_PYTHON_ABIS. Delete "test" USE flag.
*pastescript-1.7.3 (26 Apr 2009)
diff --git a/dev-python/pastescript/pastescript-1.7.3.ebuild b/dev-python/pastescript/pastescript-1.7.3.ebuild
index 6c1fe7bb7bb4..22181116d221 100644
--- a/dev-python/pastescript/pastescript-1.7.3.ebuild
+++ b/dev-python/pastescript/pastescript-1.7.3.ebuild
@@ -1,57 +1,56 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.1 2009/04/26 09:53:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.2 2009/10/01 02:33:40 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-KEYWORDS="~amd64 ~x86"
-
-MY_PN=PasteScript
-MY_P=${MY_PN}-${PV}
+MY_PN="PasteScript"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
HOMEPAGE="http://pythonpaste.org/script/"
SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
-IUSE="doc test"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+#IUSE="doc test"
RDEPEND="dev-python/paste
dev-python/pastedeploy
dev-python/cheetah"
DEPEND="${RDEPEND}
dev-python/setuptools
- doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )
- test? ( dev-python/nose )"
+ doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )"
+# test? ( dev-python/nose )
+RESTRICT_PYTHON_ABIS="3.*"
-# The tests are currently broken, needs further investigation
-RESTRICT=test
+# Tests are broken.
+RESTRICT="test"
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="paste/script"
src_compile() {
distutils_src_compile
- if use doc ; then
+ if use doc; then
einfo "Generating docs as requested..."
PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
fi
}
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
use doc && dohtml -r docs/html/*
}
-
-src_test() {
- # Tests can't import paste from site-packages
- # so we copy them over.
- # The files that will be installed are already copied to build/lib
- # so this shouldn't generate any collisions.
- distutils_python_version
- cp -pPR /usr/$(get_libdir)/python${PYVER}/site-packages/paste/* paste/
-
- PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
-}