summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-31 05:14:29 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-31 05:14:29 +0000
commit376e6c94c5aec3fa45cf23e73c0728151c7ec14b (patch)
treee1953427ca6b35caa2099b84e2736e339b90db60 /dev-python/paisley
parentMark m68k/s390/sh stable. (diff)
downloadgentoo-2-376e6c94c5aec3fa45cf23e73c0728151c7ec14b.tar.gz
gentoo-2-376e6c94c5aec3fa45cf23e73c0728151c7ec14b.tar.bz2
gentoo-2-376e6c94c5aec3fa45cf23e73c0728151c7ec14b.zip
revbump; conversion -> distutils-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/paisley')
-rw-r--r--dev-python/paisley/ChangeLog7
-rw-r--r--dev-python/paisley/paisley-0.3.1-r1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/paisley/ChangeLog b/dev-python/paisley/ChangeLog
index 5431fdf6f752..9de0e12dd5dc 100644
--- a/dev-python/paisley/ChangeLog
+++ b/dev-python/paisley/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/paisley
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/ChangeLog,v 1.17 2014/08/10 21:15:13 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/ChangeLog,v 1.18 2014/12/31 05:14:29 idella4 Exp $
+
+*paisley-0.3.1-r1 (31 Dec 2014)
+
+ 31 Dec 2014; Ian Delaney <idella4@gentoo.org> +paisley-0.3.1-r1.ebuild:
+ revbump; conversion -> distutils-r1
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> paisley-0.3.1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-python/paisley/paisley-0.3.1-r1.ebuild b/dev-python/paisley/paisley-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..bfd105dcabe0
--- /dev/null
+++ b/dev-python/paisley/paisley-0.3.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/paisley-0.3.1-r1.ebuild,v 1.1 2014/12/31 05:14:29 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils-r1
+
+DESCRIPTION="Paisley is a CouchDB client written in Python to be used within a Twisted application"
+HOMEPAGE="http://launchpad.net/paisley http://pypi.python.org/pypi/paisley"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "tests failed"
+}