summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-07-08 02:44:36 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-07-08 02:44:36 +0000
commit0b3191f0fd344c18304e8a540b4665872da8c9ae (patch)
treea95f2ed6c9529902201c0af2bb370ba07533dc63 /dev-python/oslo-concurrency
parentVersion bump. (diff)
downloadgentoo-2-0b3191f0fd344c18304e8a540b4665872da8c9ae.tar.gz
gentoo-2-0b3191f0fd344c18304e8a540b4665872da8c9ae.tar.bz2
gentoo-2-0b3191f0fd344c18304e8a540b4665872da8c9ae.zip
bup
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/ChangeLog8
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-1.8.1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/oslo-concurrency/ChangeLog b/dev-python/oslo-concurrency/ChangeLog
index 12ec54e74527..829a025eabf7 100644
--- a/dev-python/oslo-concurrency/ChangeLog
+++ b/dev-python/oslo-concurrency/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oslo-concurrency
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-concurrency/ChangeLog,v 1.5 2015/07/07 15:58:49 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-concurrency/ChangeLog,v 1.6 2015/07/08 02:44:36 prometheanfire Exp $
+
+*oslo-concurrency-1.8.1 (08 Jul 2015)
+
+ 08 Jul 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +oslo-concurrency-1.8.1.ebuild:
+ bup
07 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> oslo-concurrency-1.8.0.ebuild:
amd64 stable wrt bug #554114
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-1.8.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-1.8.1.ebuild
new file mode 100644
index 000000000000..f159d8c5d76c
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-1.8.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-concurrency/oslo-concurrency-1.8.1.ebuild,v 1.1 2015/07/08 02:44:36 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.concurrency"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+ <dev-python/oslotest-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.16.1[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.17.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.9.3[${PYTHON_USEDEP}]
+ <dev-python/oslo-config-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-i18n-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-utils-1.5.0[${PYTHON_USEDEP}]
+ dev-python/posix_ipc[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/futures/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}