summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-25 17:24:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-25 17:24:45 +0000
commitd5b319a131779d0adb01e9f3f732bf6d0ef463d2 (patch)
tree1213791a1bb65a91040cd0d7bba672ddcf98d1b5 /dev-python/oct2py/oct2py-1.3.0.ebuild
parentRemove unused patches. (diff)
downloadgentoo-2-d5b319a131779d0adb01e9f3f732bf6d0ef463d2.tar.gz
gentoo-2-d5b319a131779d0adb01e9f3f732bf6d0ef463d2.tar.bz2
gentoo-2-d5b319a131779d0adb01e9f3f732bf6d0ef463d2.zip
Fixed documentation building, bug #502310
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/oct2py/oct2py-1.3.0.ebuild')
-rw-r--r--dev-python/oct2py/oct2py-1.3.0.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/oct2py/oct2py-1.3.0.ebuild b/dev-python/oct2py/oct2py-1.3.0.ebuild
index 4a2e84847ab2..cc406824f716 100644
--- a/dev-python/oct2py/oct2py-1.3.0.ebuild
+++ b/dev-python/oct2py/oct2py-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0.ebuild,v 1.1 2014/02/23 00:24:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0.ebuild,v 1.2 2014/02/25 17:24:45 bicatali Exp $
EAPI=5
@@ -21,15 +21,18 @@ RDEPEND="
sci-libs/scipy[${PYTHON_USEDEP}]
sci-mathematics/octave"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx-bootstrap-theme
+ dev-python/numpydoc
+ )
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
- )"
+ )"
python_compile_all() {
if use doc; then
- sphinx-build doc html || die
+ sphinx-build docs html || die
fi
}