summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-05 18:21:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-05 18:21:36 +0000
commit3b258d67f18d812f9606c1cc4fb8777f02444d22 (patch)
tree563173d7bd00a1a6fa547f4c819b1233f5b29e8d /dev-python/mpi4py
parentDelete older ebuild. (diff)
downloadgentoo-2-3b258d67f18d812f9606c1cc4fb8777f02444d22.tar.gz
gentoo-2-3b258d67f18d812f9606c1cc4fb8777f02444d22.tar.bz2
gentoo-2-3b258d67f18d812f9606c1cc4fb8777f02444d22.zip
Version bump.
(Portage version: 15751-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/ChangeLog10
-rw-r--r--dev-python/mpi4py/mpi4py-1.2.1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/mpi4py/ChangeLog b/dev-python/mpi4py/ChangeLog
index e258aa35ef78..d6bf47a60581 100644
--- a/dev-python/mpi4py/ChangeLog
+++ b/dev-python/mpi4py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mpi4py
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.3 2009/12/29 21:08:44 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.4 2010/03/05 18:21:36 arfrever Exp $
+
+*mpi4py-1.2.1 (05 Mar 2010)
+
+ 05 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -mpi4py-1.1.0.ebuild, +mpi4py-1.2.1.ebuild:
+ Version bump.
*mpi4py-1.2 (29 Dec 2009)
diff --git a/dev-python/mpi4py/mpi4py-1.2.1.ebuild b/dev-python/mpi4py/mpi4py-1.2.1.ebuild
new file mode 100644
index 000000000000..dd591ceed353
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.2.1.ebuild,v 1.1 2010/03/05 18:21:36 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
+SRC_URI="http://mpi4py.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+IUSE="doc examples"
+
+DEPEND="virtual/mpi"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" mpiexec -n 2 "$(PYTHON)" test/runalltest.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/* || die "doins failed"
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r demo/* || die "doins failed"
+ fi
+}